summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomeoneonsmile2021-12-31 11:45:18 +0800
committersomeoneonsmile2021-12-31 11:45:18 +0800
commitd689d76b970ab7bf33d2677af64462c9fac03a46 (patch)
treeefeafff1bd26f26c0784f65783959da2f7f7f20b
parent586a166f8c5912c5e5f0952b4634fb584551beaf (diff)
downloadaur-d689d76b970ab7bf33d2677af64462c9fac03a46.tar.gz
update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd3df46fec1b..618ff94403d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = stow-cm
pkgdesc = config manager (simple impl of gun-stow)
pkgver = nightly
- pkgrel = 6
+ pkgrel = 1
url = https://github.com/someoneonsmile/stow
arch = x86_64
license = GPL2
makedepends = cargo
depends = gcc-libs
conflicts = stow
- source = stow-nightly.tar.gz::https://github.com/someoneonsmile/stow/archive/refs/tags/nightly.tar.gz
+ source = stow-cm::git+https://github.com/someoneonsmile/stow.git
sha512sums = SKIP
pkgname = stow-cm
diff --git a/PKGBUILD b/PKGBUILD
index 21184a239119..3c07f2c3d320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxim Baz <$pkgname at maximbaz dot com>
pkgname=stow-cm
pkgver=nightly
-pkgrel=6
+pkgrel=1
pkgdesc="config manager (simple impl of gun-stow)"
arch=('x86_64')
url="https://github.com/someoneonsmile/stow"
@@ -9,9 +9,14 @@ license=('GPL2')
depends=('gcc-libs')
makedepends=('cargo')
conflicts=('stow')
-source=("stow-$pkgver.tar.gz::https://github.com/someoneonsmile/stow/archive/refs/tags/$pkgver.tar.gz")
+source=("${pkgname}::git+https://github.com/someoneonsmile/stow.git")
sha512sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "nightly-%s.%s" "$(git rev-list --count nightly)" "$(git rev-parse --short nightly)"
+}
+
build() {
cd "stow-$pkgver"
cargo build --release