summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2023-07-10 01:37:56 +0600
committerMubashshir2023-07-10 01:37:56 +0600
commit9f96538e393c597ba185476ebf4fce8187ac854b (patch)
tree0efb8c206bb589c6e2d5d49f7800bed2eed40046
downloadaur-9f96538e393c597ba185476ebf4fce8187ac854b.tar.gz
Import from arch source repo
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD49
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74f3e72153b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = stow-dotfiles
+ pkgdesc = Manage installation of multiple softwares in the same directory tree (with AitorATuin's patches for --dotfiles)
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = https://www.gnu.org/software/stow/
+ arch = any
+ license = GPL3
+ checkdepends = perl-test-output
+ checkdepends = perl-io-stringy
+ depends = perl
+ provides = stow
+ conflicts = stow
+ source = https://ftp.gnu.org/gnu/stow/stow-2.3.1.tar.gz
+ source = https://ftp.gnu.org/gnu/stow/stow-2.3.1.tar.gz.sig
+ source = dotfiles.diff::https://patch-diff.githubusercontent.com/raw/aspiers/stow/pull/70.diff
+ validpgpkeys = 942B9075ACCA04E9037C73FED31B5563DAC1D4FA
+ sha256sums = 09d5d99671b78537fd9b2c0b39a5e9761a7a0e979f6fdb7eabfa58ee45f03d4b
+ sha256sums = SKIP
+ sha256sums = effe1387783e6f0046ad02ffb1647a083d49a887bea5e09173ea45dd5a11548f
+
+pkgname = stow-dotfiles
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d65adf6de3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25bf2dae7410
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Mubashshir <ahmubashshir@gmail.com>
+# Contributor: Brett Cornwall <ainola@archlinux.org>
+# Contributor: Sébastien Luttringer
+# Contributor: eric
+# Contributor: Tom Newsom
+# Contributor: Chris Brannon
+
+pkgname=stow-dotfiles
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="Manage installation of multiple softwares in the same directory tree (with AitorATuin's patches for --dotfiles)"
+url='https://www.gnu.org/software/stow/'
+arch=('any')
+license=('GPL3')
+depends=('perl')
+provides=('stow')
+conflicts=('stow')
+checkdepends=('perl-test-output' 'perl-io-stringy')
+validpgpkeys=('942B9075ACCA04E9037C73FED31B5563DAC1D4FA') # Adam Spiers
+source=("https://ftp.gnu.org/gnu/${pkgname%-*}/${pkgname%-*}-$pkgver.tar.gz"{,.sig}
+ "dotfiles.diff::https://patch-diff.githubusercontent.com/raw/aspiers/stow/pull/70.diff")
+sha256sums=('09d5d99671b78537fd9b2c0b39a5e9761a7a0e979f6fdb7eabfa58ee45f03d4b'
+ 'SKIP'
+ 'effe1387783e6f0046ad02ffb1647a083d49a887bea5e09173ea45dd5a11548f')
+
+prepare() {
+ cd "${pkgname%-*}-$pkgver"
+ patch -p1 < "$srcdir/dotfiles.diff"
+}
+
+build() {
+ cd "${pkgname%-*}-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-pmdir=/usr/share/perl5/vendor_perl
+ make
+}
+
+check() {
+ cd "${pkgname%-*}-$pkgver"
+ make check
+}
+
+package() {
+ cd "${pkgname%-*}-$pkgver"
+ make DESTDIR="$pkgdir" install
+}