summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2016-04-23 19:59:36 -0400
committercyrozap2016-04-23 19:59:36 -0400
commit410342e8e893c74b205b70f9a1ab5f6de8083b01 (patch)
tree47e1d5ebe03f9c4a24431e804086b206da3f690b
downloadaur-410342e8e893c74b205b70f9a1ab5f6de8083b01.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD46
-rw-r--r--cmake-git.patch17
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4b302a2b891
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sat Apr 23 23:55:27 UTC 2016
+pkgbase = stp
+ pkgdesc = Simple Theorem Prover
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = https://stp.github.io/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = bison
+ depends = boost
+ depends = flex
+ depends = minisat-git
+ source = https://github.com/stp/stp/archive/2.1.2.tar.gz
+ source = cmake-git.patch
+ sha256sums = d7f118324a534cfa33cabe7302e717f960a3d29e01c5cabc9232d21683f0085d
+ sha256sums = cedc57c9e375b145dcd9f3586505477737315194e260de0f689b7715b2088312
+
+pkgname = stp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bb6b8ac1a1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Forest Crossman <cyrozap at gmail dot com>
+
+pkgname=stp
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="Simple Theorem Prover"
+arch=('i686' 'x86_64')
+url="https://stp.github.io/"
+license=('MIT')
+depends=('bison' 'boost' 'flex' 'minisat-git')
+makedepends=('cmake' 'git')
+
+source=("https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
+ 'cmake-git.patch')
+sha256sums=('d7f118324a534cfa33cabe7302e717f960a3d29e01c5cabc9232d21683f0085d'
+ 'cedc57c9e375b145dcd9f3586505477737315194e260de0f689b7715b2088312')
+
+prepare() {
+ cd "$srcdir"
+
+ # Since we're installing from a release archive, searching for a Git
+ # directory can cause the build to fail.
+ patch -p1 < cmake-git.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Install licenses
+ install -dm 755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 LICENSE_COMPONENTS "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # Install stp
+ cd build
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cmake-git.patch b/cmake-git.patch
new file mode 100644
index 000000000000..2b86203720df
--- /dev/null
+++ b/cmake-git.patch
@@ -0,0 +1,17 @@
+--- src/stp-2.1.2/CMakeLists.txt 2015-10-28 19:35:49.000000000 -0400
++++ src/stp-2.1.2/CMakeLists.txt 2016-04-23 19:34:26.720530911 -0400
+@@ -260,14 +260,6 @@
+ PARENT_SCOPE)
+ endfunction()
+
+-find_program (GIT_EXECUTABLE git)
+-if (GIT_EXECUTABLE)
+- include(GetGitRevisionDescription)
+- get_git_head_revision(GIT_REFSPEC GIT_SHA)
+- MESSAGE(STATUS "GIT hash found: ${GIT_SHA}")
+-else()
+- set(GIT_SHA "GIT-hash-notfound")
+-endif()
+ set(STP_FULL_VERSION "2.1.2")
+
+ string(REPLACE "." ";" STP_FULL_VERSION_LIST ${STP_FULL_VERSION})