summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMads Kjeldgaard2021-09-04 11:09:28 +0200
committerMads Kjeldgaard2021-09-04 11:09:28 +0200
commita914ba4bd9ca15cf95ee28f0640584554c85031c (patch)
tree1ea1939a585ce245e086af4d9441f98fe206561b
downloadaur-a914ba4bd9ca15cf95ee28f0640584554c85031c.tar.gz
first
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
-rw-r--r--info.install36
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9175890ea95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = stpv-git
+ pkgdesc = File previewer for lf, fzf and the terminal
+ pkgver = r72.ff5ae8d
+ pkgrel = 1
+ url = https://github.com/Naheel-Azawy/stpv
+ install = info.install
+ arch = x86_64
+ groups =
+ license = GPL
+ depends = ueberzug
+ optdepends = lf: file manager that works with this script
+ optdepends = pandoc: text conversion
+ optdepends = perl-image-exiftool: image file metadata
+ optdepends = epub2txt: epub preview as text
+ optdepends = odt2txt: odt preview as text
+ optdepends = ffmpegthumbnailer: create thumbnails for videos for previews
+ optdepends = pdftoppm: pdf previews
+ optdepends = chafa: ascii previews
+ optdepends = fzf: fuzzy find with a previewer using fzfp
+ source = stpv-git::git+https://github.com/Naheel-Azawy/stpv.git
+ md5sums = SKIP
+
+pkgname = stpv-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78539de6661c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Mads Kjeldgaard <mail@madskjeldgaard.dk>
+pkgname=stpv-git
+pkgver=r72.ff5ae8d
+pkgrel=1
+pkgdesc="File previewer for lf, fzf and the terminal"
+arch=('x86_64')
+url="https://github.com/Naheel-Azawy/stpv"
+license=('GPL')
+groups=('')
+depends=('ueberzug')
+optdepends=(
+ 'lf: file manager that works with this script'
+ 'pandoc: text conversion'
+ 'perl-image-exiftool: image file metadata'
+ 'epub2txt: epub preview as text'
+ 'odt2txt: odt preview as text'
+ 'ffmpegthumbnailer: create thumbnails for videos for previews'
+ 'pdftoppm: pdf previews'
+ 'chafa: ascii previews'
+ 'fzf: fuzzy find with a previewer using fzfp'
+ )
+source=("$pkgname::git+${url}.git")
+md5sums=('SKIP')
+install=info.install
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# build() {}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -Dm755 "$srcdir/$pkgname/stpv" "$pkgdir/usr/bin/stpv"
+ install -Dm755 "$srcdir/$pkgname/stpvimg" "$pkgdir/usr/bin/stpvimg"
+ install -Dm755 "$srcdir/$pkgname/stpvimgclr" "$pkgdir/usr/bin/stpvimgclr"
+ install -Dm755 "$srcdir/$pkgname/fzfp" "$pkgdir/usr/bin/fzfp"
+
+}
diff --git a/info.install b/info.install
new file mode 100644
index 000000000000..fe4c0ec063a6
--- /dev/null
+++ b/info.install
@@ -0,0 +1,36 @@
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ echo "-------"
+ echo "stpv: Add these lines to your lf config to activate:"
+ echo -e "set previewer stpv
+set cleaner stpvimgclr
+&stpvimg --listen \$id"
+ echo "-------"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}