summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2017-06-07 23:01:17 +0200
committerAngelo Theodorou2017-06-07 23:02:07 +0200
commit72e97ae19d72094ef980b9ab72d7f48851363fd1 (patch)
treeb299f87338b8d49cce5a728e124605384f199d8e
parent7dc28a78dd6759e01e8bff0ae4a6ac0ba378e22e (diff)
downloadaur-72e97ae19d72094ef980b9ab72d7f48851363fd1.tar.gz
Update to 2.4.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
-rw-r--r--stratagus.changelog5
3 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6871928a856b..176ce04ac62a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Jun 7 21:00:35 UTC 2017
pkgbase = stratagus
pkgdesc = A free cross-platform real-time strategy gaming engine
- pkgver = 2.3.0
+ pkgver = 2.4.1
pkgrel = 1
- url = https://launchpad.net/stratagus
+ url = https://github.com/Wargus/stratagus
changelog = stratagus.changelog
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
- makedepends = tolua++
- depends = gcc-libs
depends = libgl
depends = sdl
depends = libpng
depends = libmng
- depends = libvorbis
depends = libtheora
depends = libmikmod
- depends = lua51
depends = sqlite
- source = http://launchpad.net/stratagus/trunk/2.3/+download/stratagus_2.3.0.orig.tar.gz
- md5sums = bf64b87f387c8281350e4b54327bc95f
+ depends = tolua++
+ source = stratagus::git://github.com/Wargus/stratagus.git#tag=v2.4.1
+ md5sums = SKIP
pkgname = stratagus
diff --git a/PKGBUILD b/PKGBUILD
index 5a63d705f56e..5260aec5cd06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=stratagus
-pkgver=2.3.0
+pkgver=2.4.1
pkgrel=1
pkgdesc="A free cross-platform real-time strategy gaming engine"
arch=('i686' 'x86_64')
-url="https://launchpad.net/stratagus"
+url="https://github.com/Wargus/stratagus"
license=('GPL')
-depends=('gcc-libs' 'libgl' 'sdl' 'libpng' 'libmng' 'libvorbis' 'libtheora' 'libmikmod' 'lua51' 'sqlite')
-makedepends=('cmake' 'tolua++')
+depends=('libgl' 'sdl' 'libpng' 'libmng' 'libtheora' 'libmikmod' 'sqlite' 'tolua++')
+makedepends=('cmake')
changelog=stratagus.changelog
-source=(http://launchpad.net/stratagus/trunk/2.3/+download/stratagus_$pkgver.orig.tar.gz)
-md5sums=('bf64b87f387c8281350e4b54327bc95f')
+source=("stratagus::git://github.com/Wargus/stratagus.git#tag=v2.4.1")
+md5sums=('SKIP')
build() {
cd $srcdir
- cmake ${pkgname}_$pkgver.orig \
+ cmake ${pkgname} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DGAMEDIR=/usr/bin \
@@ -29,7 +29,7 @@ build() {
package() {
cd ${srcdir}/build
make DESTDIR=${pkgdir} install
-
+
mkdir -p ${pkgdir}/usr/include
- cp ${srcdir}/${pkgname}_$pkgver.orig/gameheaders/stratagus-game-launcher.h ${pkgdir}/usr/include
+ cp ${srcdir}/stratagus/gameheaders/stratagus-game-launcher.h ${pkgdir}/usr/include
}
diff --git a/stratagus.changelog b/stratagus.changelog
index 394fc8f01048..9cd901fb7729 100644
--- a/stratagus.changelog
+++ b/stratagus.changelog
@@ -1,3 +1,8 @@
+2017-06-07 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ URL, source and dependencies updated
+
2015-04-08 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
* PKGBUILD :