summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2019-10-20 15:34:17 +0200
committerAngelo Theodorou2019-10-20 15:34:17 +0200
commitcc176cbccb507af4e04706b79550e9704061c4b9 (patch)
tree9d168659ee93ec124604d824ed7f00ef4959908b
parentd68c045b05bad1aba600b305940c2b13f4beaace (diff)
downloadaur-cc176cbccb507af4e04706b79550e9704061c4b9.tar.gz
Add patch to fix SDL GL_GLEXT_VERSION redefinition
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--glext.patch34
-rw-r--r--stratagus.changelog5
4 files changed, 52 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 016a95453132..86a439725595 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stratagus
pkgdesc = A free cross-platform real-time strategy gaming engine
pkgver = 2.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Wargus/stratagus
changelog = stratagus.changelog
arch = i686
@@ -17,7 +17,9 @@ pkgbase = stratagus
depends = sqlite
depends = tolua++
source = stratagus::git://github.com/Wargus/stratagus.git#tag=v2.4.2
+ source = glext.patch
md5sums = SKIP
+ md5sums = 1c4a52e50e0e959c5b8b58bf42930be7
pkgname = stratagus
diff --git a/PKGBUILD b/PKGBUILD
index 979539712c5f..00109a2c99ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
+# Maintainer: Angelo Theodorou <encelo at users dot sourceforge dot net>
pkgname=stratagus
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="A free cross-platform real-time strategy gaming engine"
arch=('i686' 'x86_64')
url="https://github.com/Wargus/stratagus"
@@ -9,8 +9,14 @@ license=('GPL')
depends=('libgl' 'sdl' 'libpng' 'libmng' 'libtheora' 'libmikmod' 'sqlite' 'tolua++')
makedepends=('cmake')
changelog=stratagus.changelog
-source=("stratagus::git://github.com/Wargus/stratagus.git#tag=v2.4.2")
-md5sums=('SKIP')
+source=("stratagus::git://github.com/Wargus/stratagus.git#tag=v2.4.2" glext.patch)
+md5sums=('SKIP' '1c4a52e50e0e959c5b8b58bf42930be7')
+
+prepare() {
+ cd $pkgname
+ patch --forward --strip=1 --input="${srcdir}/glext.patch"
+}
+
build() {
cd $srcdir
diff --git a/glext.patch b/glext.patch
new file mode 100644
index 000000000000..c7e9b09ec392
--- /dev/null
+++ b/glext.patch
@@ -0,0 +1,34 @@
+diff -urN stratagus.orig/src/include/video.h stratagus/src/include/video.h
+--- stratagus.orig/src/include/video.h 2019-10-20 14:59:21.017468794 +0200
++++ stratagus/src/include/video.h 2019-10-20 15:14:41.057532388 +0200
+@@ -43,6 +43,7 @@
+ #ifdef __APPLE__
+ #define GL_GLEXT_PROTOTYPES 1
+ #endif
++#define NO_SDL_GLEXT
+ #include "SDL_opengl.h"
+ #include "shaders.h"
+ #endif
+diff -urN stratagus.orig/src/video/sdl.cpp stratagus/src/video/sdl.cpp
+--- stratagus.orig/src/video/sdl.cpp 2019-10-20 14:55:55.240787855 +0200
++++ stratagus/src/video/sdl.cpp 2019-10-20 15:15:48.324203711 +0200
+@@ -53,6 +53,7 @@
+ #include <sys/stat.h>
+ #endif
+
++#define NO_SDL_GLEXT
+ #include "SDL.h"
+ #include "SDL_syswm.h"
+
+diff -urN stratagus.orig/src/video/video.cpp stratagus/src/video/video.cpp
+--- stratagus.orig/src/video/video.cpp 2019-10-20 14:55:55.240787855 +0200
++++ stratagus/src/video/video.cpp 2019-10-20 15:14:41.057532388 +0200
+@@ -93,7 +93,7 @@
+ #include "map.h"
+ #include "ui.h"
+
+-
++#define NO_SDL_GLEXT
+ #include "SDL.h"
+
+ /*----------------------------------------------------------------------------
diff --git a/stratagus.changelog b/stratagus.changelog
index 9cd901fb7729..912a04c30959 100644
--- a/stratagus.changelog
+++ b/stratagus.changelog
@@ -1,3 +1,8 @@
+2019-10-20 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Added a patch to fix the SDL redefinition of GL_GLEXT_VERSION
+
2017-06-07 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
* PKGBUILD :