summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarty Plummer2016-07-11 01:07:02 -0500
committerMarty Plummer2016-07-11 01:07:02 -0500
commit2969be071ad5d056191c3cfbcdd0d6cfb997d063 (patch)
treefd1da2bcdbc30deca11e1ffd7d6c6198ba241848
parent7dc28a78dd6759e01e8bff0ae4a6ac0ba378e22e (diff)
downloadaur-2969be071ad5d056191c3cfbcdd0d6cfb997d063.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
3 files changed, 31 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6871928a856b..3858e7163889 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-pkgbase = stratagus
- pkgdesc = A free cross-platform real-time strategy gaming engine
- pkgver = 2.3.0
+pkgbase = stratagus-git
+ pkgdesc = A free cross-platform real-time strategy gaming engine (git version)
+ pkgver = 2.4.0
pkgrel = 1
- url = https://launchpad.net/stratagus
+ url = https://github.com/Wargus/stratagus
changelog = stratagus.changelog
arch = i686
arch = x86_64
@@ -19,8 +19,11 @@ pkgbase = stratagus
depends = libmikmod
depends = lua51
depends = sqlite
- source = http://launchpad.net/stratagus/trunk/2.3/+download/stratagus_2.3.0.orig.tar.gz
- md5sums = bf64b87f387c8281350e4b54327bc95f
+ provides = stratagus=2.4.0
+ conflicts = stratagus
+ replaces = stratagus
+ source = stratagus::git://github.com/Wargus/stratagus.git
+ md5sums = SKIP
-pkgname = stratagus
+pkgname = stratagus-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6c5134b8b9e6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 5a63d705f56e..02b0c033b2bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,40 @@
+# Maintainer: Marty Plummer <ntzrmtthihu777 (at) gmail (dot) com>
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
-pkgname=stratagus
-pkgver=2.3.0
+pkgname=stratagus-git
+pkgver=2.4.0
pkgrel=1
-pkgdesc="A free cross-platform real-time strategy gaming engine"
+pkgdesc="A free cross-platform real-time strategy gaming engine (git version)"
arch=('i686' 'x86_64')
-url="https://launchpad.net/stratagus"
+url="https://github.com/Wargus/stratagus"
license=('GPL')
depends=('gcc-libs' 'libgl' 'sdl' 'libpng' 'libmng' 'libvorbis' 'libtheora' 'libmikmod' 'lua51' 'sqlite')
makedepends=('cmake' 'tolua++')
changelog=stratagus.changelog
-source=(http://launchpad.net/stratagus/trunk/2.3/+download/stratagus_$pkgver.orig.tar.gz)
-md5sums=('bf64b87f387c8281350e4b54327bc95f')
+source=("stratagus::git://github.com/Wargus/stratagus.git")
+md5sums=('SKIP')
+provides=('stratagus=2.4.0')
+replaces=('stratagus')
+conflicts=('stratagus')
build() {
- cd $srcdir
+ cd $srcdir/stratagus/
+ mkdir build/
+ cd build
- cmake ${pkgname}_$pkgver.orig \
- -DCMAKE_BUILD_TYPE=Release \
+ cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DGAMEDIR=/usr/bin \
-DSBINDIR=/usr/bin \
-DLUA_INCLUDE_DIR=/usr/include/lua5.1 \
- -Bbuild
+ ..
- make -C build
+ make
}
package() {
- cd ${srcdir}/build
+ cd ${srcdir}/stratagus/build
make DESTDIR=${pkgdir} install
mkdir -p ${pkgdir}/usr/include
- cp ${srcdir}/${pkgname}_$pkgver.orig/gameheaders/stratagus-game-launcher.h ${pkgdir}/usr/include
+ cp ${srcdir}/stratagus/gameheaders/stratagus-game-launcher.h ${pkgdir}/usr/include
}