summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorendlesseden2022-07-09 07:16:49 +1000
committerendlesseden2022-07-09 07:16:49 +1000
commitd6a2a09f337f36ea103a45d0849305d69e7fa6a3 (patch)
tree2214ada9ce23fe50ad54e716d7941ecb6d0184f7
parentdc8af70d6cae67d8cb245ca2d968f068adfdcf0a (diff)
downloadaur-d6a2a09f337f36ea103a45d0849305d69e7fa6a3.tar.gz
fixed: versioning
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD11
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aeece556ca9a..a1b3a75b1b5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stratagus-git
pkgdesc = A free cross-platform real-time strategy gaming engine
- pkgver = 2.4.4.72f8ea9e7.20200921
+ pkgver = 3.2.0.2abfb6a66.20220709
pkgrel = 1
url = https://github.com/Wargus/stratagus
arch = i686
@@ -19,7 +19,7 @@ pkgbase = stratagus-git
depends = tolua++
depends = zlib
depends = openmp
- provides = stratagus-git
+ provides = stratagus
provides = stratagus
provides = stratagus-gameutils.h
source = stratagus-git::git+https://github.com/Wargus/stratagus.git
diff --git a/PKGBUILD b/PKGBUILD
index c008a4048d60..832e61572b9d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
#Stratagus - https://github.com/Wargus/stratagus
# Original Maintainer: Angelo Theodorou <encelo at users dot sourceforge dot net>
# Maintainer: Eden Rose(endlesseden) <eenov1988 "at" gmail.com >
+_pkgname=stratagus
pkgname=stratagus-git
-pkgver=2.4.4.72f8ea9e7.20200921
+pkgver=3.2.0.2abfb6a66.20220709
pkgrel=1
pkgdesc="A free cross-platform real-time strategy gaming engine"
arch=('i686' 'x86_64')
@@ -15,16 +16,14 @@ depends=('sdl2' 'sdl2_mixer' 'sdl2_image' 'libpng' 'libmng' 'libtheora' 'libogg'
makedepends=('git' 'cmake')
source=("${pkgname}::git+https://github.com/Wargus/stratagus.git")
md5sums=('SKIP')
-provides=(${pkgname}
- 'stratagus'
- 'stratagus-gameutils.h'
-)
+provides=("$_pkgname" 'stratagus' 'stratagus-gameutils.h')
pkgver() {
cd "$srcdir/${pkgname}"
DATE="$(date +%Y%m%d)"
PV=$(git name-rev --name-only --tags --no-undefined HEAD 2>/dev/null || echo git-`git rev-parse --short HEAD`) ### get GIT version
- echo "2.4.4$PV.$DATE" | sed -e 's/git-/./g'
+ VER=$(git describe --tags | head -1 | grep v | sed 's/v//g;s/-/\n/g' | head -1)
+ echo "$VER$PV.$DATE" | sed -e 's/git-/./g'
}
build() {