summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-08-08 20:50:20 -0500
committerDan Beste2017-08-08 20:50:20 -0500
commit00100fbd52471ad0cf5ed220b7c5bf870a50931e (patch)
tree50584e224be00fb310c60ba7576f1a8dcbc74a88
downloadaur-00100fbd52471ad0cf5ed220b7c5bf870a50931e.tar.gz
Init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD38
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00f40a705cfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stratis-cli-git
+ pkgdesc = ???
+ pkgver = v0.0.2.r3.gbf0beb6
+ pkgrel = 1
+ url = https://github.com/stratis-storage/stratis-cli.git
+ arch = any
+ license = apache2
+ makedepends = git
+ depends = python-argparse
+ provides = stratis-cli
+ conflicts = stratis-cli
+ source = git+https://github.com/stratis-storage/stratis-cli.git
+ sha256sums = SKIP
+
+pkgname = stratis-cli-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bc9028b62ecb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.SRCINFO
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..960b582a93d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Dan Beste <Dan.Ray.Beste@gmail.com>
+
+pkgname='stratis-cli-git'
+_gitname='stratis-cli'
+pkgver=v0.0.2.r3.gbf0beb6
+pkgrel=1
+pkgdesc='???'
+arch=('any')
+license=('apache2')
+url='https://github.com/stratis-storage/stratis-cli.git'
+depends=('python-argparse')
+makedepends=('git')
+provides=("${_gitname}")
+conflicts=("${_gitname}")
+source=(
+ 'git+https://github.com/stratis-storage/stratis-cli.git'
+)
+sha256sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "${_gitname}"
+
+ git describe --tags --long \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${_gitname}"
+
+ install -d "${pkgdir}/usr/share/licenses/"
+
+ install -m 644 LICENSE "${pkgdir}/usr/share/licenses/"
+ python setup.py install --root="${pkgdir}"
+}
+
+# vim: ts=2 sw=2 et: