summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-11-07 20:46:19 -0600
committerDan Beste2017-11-07 20:47:02 -0600
commitecbf3226716831b40514c3bd3802ca9c809cfbfd (patch)
tree7ec867037e01ebbb6dc912f365fffb792c6687a7
parent464842bde59832c8555fad66eb82c2c89ee5ce9c (diff)
downloadaur-ecbf3226716831b40514c3bd3802ca9c809cfbfd.tar.gz
v0.0.4.r19.gdc091e4
* PKGBUILD: Add missing dependencies. * PKGBUILD: Add check() function * PKGBUILD: package() optimize install
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c58e0247c8cb..fb2ef7f80eff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = stratis-cli-git
pkgdesc = stratis-cli is a tool that provides a command-line interface (CLI) for interacting with the Stratis daemon, stratisd.
- pkgver = v0.0.2.r3.gbf0beb6
+ pkgver = 0.0.4.r19.gdc091e4
pkgrel = 1
url = stratis-storage.github.io
arch = any
license = apache2
makedepends = git
depends = python-argparse
+ depends = python-dbus
+ depends = python-justbytes
provides = stratis-cli
conflicts = stratis-cli
source = git+https://github.com/stratis-storage/stratis-cli.git
diff --git a/PKGBUILD b/PKGBUILD
index 29f546f23d5c..af427e353850 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: Dan Beste <Dan.Ray.Beste@gmail.com>
pkgname='stratis-cli-git'
-_gitname='stratis-cli'
-pkgver=v0.0.2.r3.gbf0beb6
+pkgver=0.0.4.r19.gdc091e4
pkgrel=1
pkgdesc='stratis-cli is a tool that provides a command-line interface (CLI) for interacting with the Stratis daemon, stratisd.'
arch=('any')
license=('apache2')
url='stratis-storage.github.io'
-depends=('python-argparse')
+depends=('python-argparse' 'python-dbus' 'python-justbytes')
makedepends=('git')
-provides=("${_gitname}")
-conflicts=("${_gitname}")
+provides=("${pkgname/-git}")
+conflicts=("${pkgname/-git}")
source=(
'git+https://github.com/stratis-storage/stratis-cli.git'
)
@@ -20,20 +19,26 @@ sha256sums=(
)
pkgver() {
- cd "${_gitname}"
+ cd "${pkgname/-git}"
git describe --tags --long \
| sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
| sed 's/v//'
}
+check() {
+ cd "${pkgname/-git}"
+
+ tox
+}
+
package() {
- cd "${_gitname}"
+ cd "${pkgname/-git}"
install -d "${pkgdir}/usr/share/licenses/"
install -m 644 LICENSE "${pkgdir}/usr/share/licenses/"
- python setup.py install --root="${pkgdir}"
+ python setup.py install --root="${pkgdir}" --optimize=1
}
# vim: ts=2 sw=2 et: