summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2018-04-08 22:48:00 -0500
committerDan Beste2018-04-08 22:48:00 -0500
commit931c853a71db57caff877a53a6dca4f255f7ce24 (patch)
tree8bf230dc55a680cb6779eb42138bfd542558abbe
parent2f3bc27426ad5ea6c96f9cc05b2c8c27d7999c4f (diff)
downloadaur-931c853a71db57caff877a53a6dca4f255f7ce24.tar.gz
v0.5.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5031e6b08d9..d00461987548 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = stratisd
pkgdesc = Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.
- pkgver = 0.5.0
+ pkgver = 0.5.1
pkgrel = 1
url = https://stratis-storage.github.io/
- arch = i686
arch = x86_64
license = MPL2
+ makedepends = asciidoc
makedepends = cargo
makedepends = git
makedepends = rust
provides = stratisd
conflicts = stratisd
- source = stratisd-0.5.0.tar.gz::https://github.com/stratis-storage/stratisd/archive/v0.5.0.tar.gz
- sha256sums = 0d6e6ecaf46282e4696431d2616bf140b907c2a39084179e2658993c2654d40c
+ source = stratisd-0.5.1.tar.gz::https://github.com/stratis-storage/stratisd/archive/v0.5.1.tar.gz
+ sha256sums = 668792b4fde50fcca6410ff689eda1bd62f5c23f185f652b7a08fe7e9e458808
pkgname = stratisd
diff --git a/PKGBUILD b/PKGBUILD
index af700507aa80..a417acdb5480 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
pkgname='stratisd'
-pkgver=0.5.0
+pkgver=0.5.1
pkgrel=1
pkgdesc='Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://stratis-storage.github.io/'
license=('MPL2')
-makedepends=('cargo' 'git' 'rust')
+makedepends=('asciidoc' 'cargo' 'git' 'rust')
provides=("${pkgname}")
conflicts=("${pkgname}")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/stratis-storage/stratisd/archive/v${pkgver}.tar.gz")
-sha256sums=('0d6e6ecaf46282e4696431d2616bf140b907c2a39084179e2658993c2654d40c')
+sha256sums=('668792b4fde50fcca6410ff689eda1bd62f5c23f185f652b7a08fe7e9e458808')
build() {
cd "${pkgname}-${pkgver}"
- cargo build --release
- cargo doc --no-deps
+ # Append '--release' to `cargo build` (line 24):
+ sed -i '24s/cargo build/cargo build --release/' Makefile
+ # Release
+ make build
+ make docs
}
check() {
@@ -29,13 +32,19 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
+ install -d -m 755 "${pkgdir}/etc/dbus-1/system.d"
install -d -m 755 "${pkgdir}/usr/bin/"
+ install -d -m 755 "${pkgdir}/usr/lib/systemd/system"
install -d -m 755 "${pkgdir}/usr/share/doc/"
install -d -m 755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d -m 755 "${pkgdir}/usr/share/man/man8"
- install -m 755 target/release/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
- install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m 755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -m 644 stratisd.service "${pkgdir}/usr/lib/systemd/system"
+ install -m 644 stratisd.conf "${pkgdir}/etc/dbus-1/system.d"
+ install -m 644 docs/stratisd.8 "${pkgdir}/usr/share/man/man8"
cp -r target/doc/* "${pkgdir}/usr/share/doc/"
+ install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et: