summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-10-19 22:05:48 -0500
committerDan Beste2017-10-19 22:05:48 -0500
commit40ccc5e12e3f6d5006bf69b5e8cccf09bb9f865f (patch)
tree943d56df2b4cbc985e053212f61f4be4843a1c46
parent20c734a2c1c5a590e2988f35d4002b2d9af343a9 (diff)
downloadaur-40ccc5e12e3f6d5006bf69b5e8cccf09bb9f865f.tar.gz
v0.1.1
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD8
3 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44e85e411960..10ee6455d90e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stratisd-git
pkgdesc = Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.
- pkgver = 0.1.0.r7.g9204a4d
+ pkgver = 0.1.1.r39.g91c6498
pkgrel = 1
url = https://stratis-storage.github.io/
arch = i686
diff --git a/.gitignore b/.gitignore
index 9865d22ba8ed..bc9028b62ecb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,6 @@
*
# Whitelist:
+!.SRCINFO
!.gitignore
!PKGBUILD
-!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 861d6c438ab2..af2a9cc53930 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='stratisd-git'
_gitname='stratisd'
-pkgver=0.1.0.r7.g9204a4d
+pkgver=0.1.1.r39.g91c6498
pkgrel=1
pkgdesc='Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.'
arch=('i686' 'x86_64')
@@ -20,15 +20,13 @@ pkgver() {
cd "${_gitname}"
git describe --long --tags \
- | sed 's/v//' \
- | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${_gitname}"
- cargo build --release
- cargo doc --no-deps
+ make
}
check() {