summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-16 12:36:43 +0200
committerGoliathLabs2020-05-16 12:36:43 +0200
commit4a063fa130b361cb469eb86343233ab255b56526 (patch)
tree761741d7ebb98405c0301f305240b58c776679d1
parente0138eb35fcad10a086c854c7826072f94e99595 (diff)
downloadaur-4a063fa130b361cb469eb86343233ab255b56526.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD53
2 files changed, 30 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15d2fbd6df49..fbd34610bb39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
pkgbase = stratisd-git
- pkgdesc = Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.
- pkgver = 0.5.1.r21.gc118733
+ pkgdesc = Easy to use local storage management for Linux.
+ pkgver = 2.0.1.r334.g35374c4d
pkgrel = 1
url = https://stratis-storage.github.io/
arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = MPL2
makedepends = asciidoc
makedepends = cargo
makedepends = git
makedepends = rust
+ depends = dbus
+ optdepends = stratis-cli: command line interface
provides = stratisd
conflicts = stratisd
source = git+https://github.com/stratis-storage/stratisd.git
diff --git a/PKGBUILD b/PKGBUILD
index 05a65788f659..412eb43dc35a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,51 @@
-# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Dan Beste <dan.ray.beste@gmail.com>
pkgname='stratisd-git'
-pkgver=0.5.1.r21.gc118733
+pkgver=2.0.1.r334.g35374c4d
pkgrel=1
-pkgdesc='Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.'
-arch=('i686' 'x86_64')
+pkgdesc='Easy to use local storage management for Linux.'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url='https://stratis-storage.github.io/'
license=('MPL2')
makedepends=('asciidoc' 'cargo' 'git' 'rust')
+depends=('dbus')
+optdepends=('stratis-cli: command line interface')
provides=("${pkgname/-git}")
conflicts=("${pkgname/-git}")
source=('git+https://github.com/stratis-storage/stratisd.git')
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname/-git}"
-
- git describe --long --tags \
- | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${srcdir}/${pkgname/-git}"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname/-git}"
+ cd "${srcdir}/${pkgname/-git}"
+
+ sed -i 's,/usr/libexec,/usr/bin,g' stratisd.service
- # Append '--release' to `cargo build` (line 31):
- sed -i '31s/cargo build/cargo build --release/' Makefile
# Release
- make build
- make docs
+ make release
+ make stratisd.8
}
check() {
- cd "${pkgname/-git}"
+ cd "${srcdir}/${pkgname/-git}"
make test
}
package() {
- cd "${pkgname/-git}"
-
- install -d -m 755 "${pkgdir}/etc/dbus-1/system.d"
- install -d -m 755 "${pkgdir}/usr/bin/"
- install -d -m 755 "${pkgdir}/usr/lib/systemd/system"
- install -d -m 755 "${pkgdir}/usr/share/doc/"
- install -d -m 755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -d -m 755 "${pkgdir}/usr/share/man/man8"
-
- install -m 755 "target/x86_64-unknown-linux-gnu/release/${pkgname/-git}" \
- "${pkgdir}/usr/bin/${pkgname/-git}"
- install -m 644 stratisd.service "${pkgdir}/usr/lib/systemd/system"
- install -m 644 stratisd.conf "${pkgdir}/etc/dbus-1/system.d"
- install -m 644 docs/stratisd.8 "${pkgdir}/usr/share/man/man8"
- cp -r target/doc/* "${pkgdir}/usr/share/doc/"
- install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/${pkgname/-git}"
+
+ install -D -m755 "target/release/${pkgname/-git}" "${pkgdir}/usr/bin/${pkgname/-git}"
+ install -D -m644 stratisd.service "${pkgdir}/usr/lib/systemd/system/stratisd.service"
+ install -D -m644 org.storage.stratis2.service "${pkgdir}/usr/share/dbus-1/system-services/org.storage.stratis2.service"
+ install -D -m644 stratisd.conf "${pkgdir}/usr/share/dbus-1/system.d/stratisd.conf"
+ install -D -m644 docs/stratisd.8 "${pkgdir}/usr/share/man/man8/stratisd.8"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname/-git}/LICENSE"
}
# vim: ts=2 sw=2 et: