summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2018-04-08 23:06:10 -0500
committerDan Beste2018-04-08 23:06:10 -0500
commite0138eb35fcad10a086c854c7826072f94e99595 (patch)
tree6e593b7afcd5dcbe1daba860d4ff338d71f62519
parent99875284d989eff967b835e2a1168370f795ad4c (diff)
downloadaur-e0138eb35fcad10a086c854c7826072f94e99595.tar.gz
v0.5.1-git
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1a49bc5ab3c..15d2fbd6df49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = stratisd-git
pkgdesc = Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.
- pkgver = 0.1.2.r11.g3a8dbd9
+ pkgver = 0.5.1.r21.gc118733
pkgrel = 1
url = https://stratis-storage.github.io/
arch = i686
arch = x86_64
license = MPL2
+ makedepends = asciidoc
makedepends = cargo
makedepends = git
makedepends = rust
diff --git a/PKGBUILD b/PKGBUILD
index b73a31c43f4d..05a65788f659 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
pkgname='stratisd-git'
-pkgver=0.1.2.r11.g3a8dbd9
+pkgver=0.5.1.r21.gc118733
pkgrel=1
pkgdesc='Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.'
arch=('i686' 'x86_64')
url='https://stratis-storage.github.io/'
license=('MPL2')
-makedepends=('cargo' 'git' 'rust')
+makedepends=('asciidoc' 'cargo' 'git' 'rust')
provides=("${pkgname/-git}")
conflicts=("${pkgname/-git}")
source=('git+https://github.com/stratis-storage/stratisd.git')
@@ -23,8 +23,11 @@ pkgver() {
build() {
cd "${pkgname/-git}"
- cargo build --release
- cargo doc --no-deps
+ # Append '--release' to `cargo build` (line 31):
+ sed -i '31s/cargo build/cargo build --release/' Makefile
+ # Release
+ make build
+ make docs
}
check() {
@@ -36,13 +39,20 @@ check() {
package() {
cd "${pkgname/-git}"
+ install -d -m 755 "${pkgdir}/etc/dbus-1/system.d"
install -d -m 755 "${pkgdir}/usr/bin/"
+ install -d -m 755 "${pkgdir}/usr/lib/systemd/system"
install -d -m 755 "${pkgdir}/usr/share/doc/"
- install -d -m 755 "${pkgdir}/usr/share/licenses/${pkgname/-git}"
-
- install -m 755 target/release/${pkgname/-git} "${pkgdir}/usr/bin/${pkgname/-git}"
- install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname/-git}/LICENSE"
+ install -d -m 755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d -m 755 "${pkgdir}/usr/share/man/man8"
+
+ install -m 755 "target/x86_64-unknown-linux-gnu/release/${pkgname/-git}" \
+ "${pkgdir}/usr/bin/${pkgname/-git}"
+ install -m 644 stratisd.service "${pkgdir}/usr/lib/systemd/system"
+ install -m 644 stratisd.conf "${pkgdir}/etc/dbus-1/system.d"
+ install -m 644 docs/stratisd.8 "${pkgdir}/usr/share/man/man8"
cp -r target/doc/* "${pkgdir}/usr/share/doc/"
+ install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et: