summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer2018-07-31 13:57:49 +0800
committerquininer2018-07-31 13:58:31 +0800
commitd73e37d64d3fd253a41f2b3bbfc7a60e1b3bc3f0 (patch)
treeeb2486399132c68b72622382cc9e896e4644f036
downloadaur-d73e37d64d3fd253a41f2b3bbfc7a60e1b3bc3f0.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD54
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80a5a9059158
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = stratisd-single
+ pkgdesc = Easy to use local storage management for Linux.
+ pkgver = 0.5.4
+ pkgrel = 0
+ url = https://stratis-storage.github.io/
+ arch = x86_64
+ license = MPL2
+ makedepends = asciidoc
+ makedepends = cargo
+ makedepends = rust
+ makedepends = git
+ provides = stratisd
+ conflicts = stratisd
+ source = stratisd-0.5.4.tar.gz::https://github.com/stratis-storage/stratisd/archive/v0.5.4.tar.gz
+ sha256sums = 373493ff36684e6595c1377af9f34cd7f6389a7a74921c84355608f75e208422
+
+pkgname = stratisd-single
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dce635fad9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# fork https://aur.archlinux.org/stratisd.git
+
+pkgname='stratisd-single'
+_pkgname='stratisd'
+pkgver=0.5.4
+pkgrel=0
+pkgdesc='Easy to use local storage management for Linux.'
+arch=('x86_64')
+url='https://stratis-storage.github.io/'
+license=('MPL2')
+makedepends=('asciidoc' 'cargo' 'rust' 'git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/stratis-storage/stratisd/archive/v${pkgver}.tar.gz")
+sha256sums=('373493ff36684e6595c1377af9f34cd7f6389a7a74921c84355608f75e208422')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+
+ # Append '--release' to `cargo build` (line 24):
+ sed -i 's/cargo build --target/cargo build --release --target/' Makefile
+
+ # Release
+ make build
+ make stratisd.8
+
+ # patch systemd config
+ sed -i 's,/usr/libexec,/usr/bin,g' stratisd.service
+}
+
+check() {
+ cd "${_pkgname}-${pkgver}"
+
+ make test
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ install -d -m 755 "${pkgdir}/etc/dbus-1/system.d"
+ install -d -m 755 "${pkgdir}/usr/bin/"
+ install -d -m 755 "${pkgdir}/usr/lib/systemd/system"
+ install -d -m 755 "${pkgdir}/usr/share/dbus-1/system-services"
+ install -d -m 755 "${pkgdir}/usr/share/doc/"
+ install -d -m 755 "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -d -m 755 "${pkgdir}/usr/share/man/man8"
+
+ install -m 755 "target/x86_64-unknown-linux-gnu/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -m 644 stratisd.service "${pkgdir}/usr/lib/systemd/system"
+ install -m 644 org.storage.stratis1.service "${pkgdir}/usr/share/dbus-1/system-services"
+ install -m 644 stratisd.conf "${pkgdir}/etc/dbus-1/system.d"
+ install -m 644 docs/stratisd.8 "${pkgdir}/usr/share/man/man8"
+ install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}