summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2020-07-15 17:50:56 +0300
committertrizen2020-07-15 17:50:56 +0300
commitef65e06f287cd92bb41b194fee25259c0b0af509 (patch)
treef9d82e0c00d134eb8207e968243306df377e6bbf
parentd06f116da1870d63f00ec488c382117d640021c5 (diff)
downloadaur-ef65e06f287cd92bb41b194fee25259c0b0af509.tar.gz
Use `git describe --long` in pkgver()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 052fba11fe81..9bb2f024547e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = straw-viewer-git
pkgdesc = Application for searching and streaming videos from YouTube, using the API of invidio.us (fork of youtube-viewer).
- pkgver = 0.0.6
+ pkgver = 0.0.6.r0.g7332262
pkgrel = 1
url = https://github.com/trizen/straw-viewer
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index cf0a3eaf8819..5b6cb7b0e127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=straw-viewer
pkgname=straw-viewer-git
-pkgver=0.0.6
+pkgver=0.0.6.r0.g7332262
pkgrel=1
pkgdesc="Application for searching and streaming videos from YouTube, using the API of invidio.us (fork of youtube-viewer)."
arch=('any')
@@ -32,8 +32,8 @@ source=("git+https://github.com/trizen/${_pkgname}.git")
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- git describe --always | sed -e 's|-|.|g'
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {