summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-04-07 23:19:52 +0200
committerFabioLolix2023-04-07 23:19:52 +0200
commit363a8673eaa270a4b73d932cd95f3f0817487c16 (patch)
treecd1c4cddd5e26beaaecd10309cbe5c817a424d36
parent663f2fc76e93da8e7f571f30a04b5a6c5a9eb96a (diff)
downloadaur-363a8673eaa270a4b73d932cd95f3f0817487c16.tar.gz
revision
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a65f3e584cbf..22b83f1e8f4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = strawberry-full-git
pkgdesc = A music player aimed at audio enthusiasts and music collectors, all options and engines
- pkgver = 1.0.0.r0.g9d18f40c
+ pkgver = 1.0.17.r14.ge314545f
pkgrel = 1
url = https://www.strawberrymusicplayer.org/
arch = x86_64
arch = i686
- arch = arm
- arch = armv6h
arch = armv7h
arch = aarch64
license = GPL3
@@ -21,7 +19,7 @@ pkgbase = strawberry-full-git
depends = gst-plugins-base
depends = gst-plugins-good
depends = qt6-base
- depends = sqlite3
+ depends = sqlite
depends = udisks2
depends = dbus
depends = alsa-lib
diff --git a/PKGBUILD b/PKGBUILD
index 0a16d5023a9e..94d3402e488d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=strawberry-full-git
-pkgver=1.0.0.r0.g9d18f40c
+pkgver=1.0.17.r14.ge314545f
pkgrel=1
pkgdesc="A music player aimed at audio enthusiasts and music collectors, all options and engines"
-arch=(x86_64 i686 arm armv6h armv7h aarch64)
+arch=(x86_64 i686 armv7h aarch64)
url="https://www.strawberrymusicplayer.org/"
license=(GPL3)
depends=(chromaprint protobuf gst-plugins-base gst-plugins-good qt6-base
- sqlite3 udisks2 dbus alsa-lib fftw
+ sqlite udisks2 dbus alsa-lib fftw
libcdio vlc libgpod
- libpulse libmtp libusbmuxd libplist libimobiledevice)
+ libpulse libmtp libusbmuxd libplist libimobiledevice)
makedepends=(git cmake boost qt6-tools gtest gmock)
optdepends=('gst-libav: additional codecs (i.e. AAC)'
'gst-plugins-bad: additional codecs (i.e. AAC)'
@@ -21,17 +21,17 @@ source=("git+https://github.com/jonaski/strawberry.git")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname/-full-git/}"
+ cd strawberry
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${pkgname/-full-git/}"
+ cd strawberry
install -d strawberry-build
}
build() {
- cd "${pkgname/-full-git/}/strawberry-build"
+ cd strawberry/strawberry-build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_WITH_QT6=ON
@@ -40,6 +40,6 @@ build() {
}
package() {
- cd "${pkgname/-full-git/}/strawberry-build"
+ cd strawberry/strawberry-build
make DESTDIR="${pkgdir}" install
}