summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-09-23 23:05:02 +0200
committerFabioLolix2018-09-23 23:05:02 +0200
commit7a60090fab9b516e92c8865c62f49a409fc5b5b2 (patch)
tree77c96aaf58a5943116b5bbb0e2a2fa7c4540a4fb
parent2df2732ef69d34732be3a57a98b1eb32aee8dd70 (diff)
downloadaur-7a60090fab9b516e92c8865c62f49a409fc5b5b2.tar.gz
Update deps, improvements for shared sources
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2efa01d8aea..1c8f0f6e5984 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = strawberry-full-git
pkgdesc = Bitperfect audio player and music collection organizer, fork of Clementine. gstreamer, xine and vlc engines
- pkgver = 0.2.1.r39.g1a55b7f
+ pkgver = 0.3.1.r10.gdb5679b
pkgrel = 1
url = http://www.strawbs.org/
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = strawberry-full-git
depends = chromaprint
depends = protobuf
depends = gst-plugins-base
- depends = boost-libs
+ depends = gst-plugins-good
depends = qt5-base
depends = qt5-x11extras
depends = sqlite3
@@ -34,13 +34,12 @@ pkgbase = strawberry-full-git
depends = libusbmuxd
depends = libplist
depends = libimobiledevice
- optdepends = gst-plugins-good
optdepends = gst-plugins-bad
optdepends = gst-plugins-ugly
provides = strawberry
conflicts = strawberry
conflicts = strawberry-git
- source = strawberry-full-git::git+https://github.com/jonaski/strawberry.git
+ source = strawberry-git::git+https://github.com/jonaski/strawberry.git
sha256sums = SKIP
pkgname = strawberry-full-git
diff --git a/PKGBUILD b/PKGBUILD
index f8d1e3aec9dc..b864263d4dca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,42 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=strawberry-full-git
-pkgver=0.2.1.r39.g1a55b7f
+pkgver=0.3.1.r10.gdb5679b
pkgrel=1
pkgdesc="Bitperfect audio player and music collection organizer, fork of Clementine. gstreamer, xine and vlc engines"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="http://www.strawbs.org/"
license=(GPL3)
-depends=(chromaprint protobuf gst-plugins-base boost-libs qt5-base qt5-x11extras
+depends=(chromaprint protobuf gst-plugins-base gst-plugins-good qt5-base qt5-x11extras
sqlite3 udisks2 pulseaudio dbus alsa-lib
libcdio taglib)
depends+=(xine-lib vlc libmtp phonon-qt5 libgpod libusbmuxd libplist libimobiledevice)
makedepends=(git cmake boost)
-optdepends=(gst-plugins-good
- gst-plugins-bad
+optdepends=(gst-plugins-bad
gst-plugins-ugly)
provides=(strawberry)
conflicts=(strawberry strawberry-git)
-source=("${pkgname}::git+https://github.com/jonaski/strawberry.git")
+source=("strawberry-git::git+https://github.com/jonaski/strawberry.git")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd "strawberry-git"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/strawberry-git"
install -d strawberry-build
}
build() {
- cd "${srcdir}/${pkgname}/strawberry-build"
+ cd "${srcdir}/strawberry-git/strawberry-build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd "${srcdir}/${pkgname}/strawberry-build"
+ cd "${srcdir}/strawberry-git/strawberry-build"
make DESTDIR="${pkgdir}" install
}