summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-09-23 23:06:01 +0200
committerFabioLolix2018-09-23 23:06:01 +0200
commit2d88fb960a5d1c145b15262ec521b363804ef12d (patch)
treee3937a788da0cdd0458f368f0e3139f53c6bdc86
parent98ed1860d283969e1319d2ad690586ca581992f1 (diff)
downloadaur-2d88fb960a5d1c145b15262ec521b363804ef12d.tar.gz
Update deps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d90dd5369255..607b43e58410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = strawberry-git
pkgdesc = Bitperfect audio player and music collection organizer, fork of Clementine. gstreamer engine only
- pkgver = 0.2.1.r39.g1a55b7f
+ pkgver = 0.3.1.r29.g36563cd
pkgrel = 1
url = http://www.strawbs.org/
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = strawberry-git
depends = chromaprint
depends = protobuf
depends = gst-plugins-base
- depends = boost-libs
+ depends = gst-plugins-good
depends = qt5-base
depends = qt5-x11extras
depends = sqlite3
@@ -26,7 +26,6 @@ pkgbase = strawberry-git
depends = alsa-lib
depends = libcdio
depends = taglib
- optdepends = gst-plugins-good
optdepends = gst-plugins-bad
optdepends = gst-plugins-ugly
provides = strawberry
diff --git a/PKGBUILD b/PKGBUILD
index 4faf7f34edbf..e8af9958b2d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=strawberry-git
-pkgver=0.2.1.r39.g1a55b7f
+pkgver=0.3.1.r29.g36563cd
pkgrel=1
pkgdesc="Bitperfect audio player and music collection organizer, fork of Clementine. gstreamer engine only"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="http://www.strawbs.org/"
license=(GPL3)
-depends=(chromaprint protobuf gst-plugins-base boost-libs qt5-base qt5-x11extras
+depends=(chromaprint protobuf gst-plugins-base gst-plugins-good qt5-base qt5-x11extras
sqlite3 udisks2 pulseaudio dbus alsa-lib
libcdio taglib)
-#depends+=(xine-lib vlc libmtp phonon-qt5 libgpod libusbmuxd libplist libimobiledevice)
+#depends+=(libimobiledevice libplist libusbmuxd libgpod libmtp phonon-qt5 vlc xine-lib) #customize deps and flags at your needs
makedepends=(git cmake boost)
-optdepends=(gst-plugins-good
- gst-plugins-bad
+optdepends=(gst-plugins-bad
gst-plugins-ugly)
provides=(strawberry)
conflicts=(strawberry strawberry-full-git)
@@ -33,7 +32,16 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}/strawberry-build"
cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_SYSTEM_TAGLIB=ON \
+ -DENABLE_IMOBILEDEVICE=OFF \
+ -DENABLE_LIBGPOD=OFF \
+ -DENABLE_LIBMTP=OFF \
+ -DENABLE_LIBLASTFM=OFF \
+ -DENABLE_PHONON=OFF \
+ -DENABLE_SPARKLE=OFF \
+ -DENABLE_VLC=OFF \
+ -DENABLE_XINE=OFF
make
}