summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-11-13 23:08:11 +0100
committerFabioLolix2018-11-13 23:08:11 +0100
commit951dbca27bc3ceb9c963e7ee70b4d335d95bb987 (patch)
treec7377be7193db4809f67aac36e0f99a09c67d13d
parenta336155460e5713d724b3a95ce1e658af5b065da (diff)
downloadaur-951dbca27bc3ceb9c963e7ee70b4d335d95bb987.tar.gz
flag & deps change
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee028c39eb9c..e309c734f482 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = strawberry-git
pkgdesc = Bitperfect audio player and music collection organizer, fork of Clementine. gstreamer engine only
- pkgver = 0.3.3.r17.g4aad44c
+ pkgver = 0.4.1.r16.gb357634
pkgrel = 2
url = http://www.strawbs.org/
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = strawberry-git
makedepends = git
makedepends = cmake
makedepends = boost
+ makedepends = libpulse
depends = chromaprint
depends = protobuf
depends = gst-plugins-base
@@ -21,17 +22,16 @@ pkgbase = strawberry-git
depends = qt5-x11extras
depends = sqlite3
depends = udisks2
- depends = pulseaudio
depends = dbus
depends = alsa-lib
depends = libcdio
depends = taglib
+ optdepends = libpulse: pulseaudio backend
optdepends = gst-plugins-bad
optdepends = gst-plugins-ugly
provides = strawberry
conflicts = strawberry
- conflicts = strawberry-full-git
- source = strawberry-git::git+https://github.com/jonaski/strawberry.git
+ source = git+https://github.com/jonaski/strawberry.git
sha256sums = SKIP
pkgname = strawberry-git
diff --git a/PKGBUILD b/PKGBUILD
index b04f2d4b5eb2..863b9d94d45c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,41 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=strawberry-git
-pkgver=0.3.3.r17.g4aad44c
+pkgver=0.4.1.r16.gb357634
pkgrel=2
pkgdesc="Bitperfect audio player and music collection organizer, fork of Clementine. gstreamer engine only"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="http://www.strawbs.org/"
license=(GPL3)
depends=(chromaprint protobuf gst-plugins-base gst-plugins-good qt5-base qt5-x11extras
- sqlite3 udisks2 pulseaudio dbus alsa-lib
+ sqlite3 udisks2 dbus alsa-lib
libcdio taglib)
#depends+=(libimobiledevice libplist libusbmuxd libgpod libmtp phonon-qt5 vlc xine-lib) #customize deps and flags at your needs
-makedepends=(git cmake boost)
-optdepends=(gst-plugins-bad
+makedepends=(git cmake boost libpulse)
+optdepends=('libpulse: pulseaudio backend'
+ gst-plugins-bad
gst-plugins-ugly)
provides=(strawberry)
-conflicts=(strawberry strawberry-full-git)
-source=("${pkgname}::git+https://github.com/jonaski/strawberry.git")
+conflicts=(strawberry)
+source=("git+https://github.com/jonaski/strawberry.git")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd "${pkgname/-git/}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname/-git/}"
install -d strawberry-build
}
build() {
- cd "${srcdir}/${pkgname}/strawberry-build"
+ cd "${pkgname/-git/}/strawberry-build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_SYSTEM_TAGLIB=ON \
+ -DENABLE_STREAM_DEEZER=OFF \
-DENABLE_IMOBILEDEVICE=OFF \
-DENABLE_LIBGPOD=OFF \
-DENABLE_LIBMTP=OFF \
@@ -46,6 +48,6 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}/strawberry-build"
+ cd "${pkgname/-git/}/strawberry-build"
make DESTDIR="${pkgdir}" install
}