summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-08-10 11:19:02 +0200
committerFabioLolix2018-08-10 11:19:02 +0200
commit98ed1860d283969e1319d2ad690586ca581992f1 (patch)
tree61d496bdc1cafe50ad6d7bd19ccd47deb0ab6f2f
downloadaur-98ed1860d283969e1319d2ad690586ca581992f1.tar.gz
Initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD43
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d90dd5369255
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = strawberry-git
+ pkgdesc = Bitperfect audio player and music collection organizer, fork of Clementine. gstreamer engine only
+ pkgver = 0.2.1.r39.g1a55b7f
+ pkgrel = 1
+ url = http://www.strawbs.org/
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = chromaprint
+ depends = protobuf
+ depends = gst-plugins-base
+ depends = boost-libs
+ depends = qt5-base
+ depends = qt5-x11extras
+ depends = sqlite3
+ depends = udisks2
+ depends = pulseaudio
+ depends = dbus
+ depends = alsa-lib
+ depends = libcdio
+ depends = taglib
+ optdepends = gst-plugins-good
+ optdepends = gst-plugins-bad
+ optdepends = gst-plugins-ugly
+ provides = strawberry
+ conflicts = strawberry
+ conflicts = strawberry-full-git
+ source = strawberry-git::git+https://github.com/jonaski/strawberry.git
+ sha256sums = SKIP
+
+pkgname = strawberry-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4faf7f34edbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+
+pkgname=strawberry-git
+pkgver=0.2.1.r39.g1a55b7f
+pkgrel=1
+pkgdesc="Bitperfect audio player and music collection organizer, fork of Clementine. gstreamer engine only"
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url="http://www.strawbs.org/"
+license=(GPL3)
+depends=(chromaprint protobuf gst-plugins-base boost-libs qt5-base qt5-x11extras
+ sqlite3 udisks2 pulseaudio dbus alsa-lib
+ libcdio taglib)
+#depends+=(xine-lib vlc libmtp phonon-qt5 libgpod libusbmuxd libplist libimobiledevice)
+makedepends=(git cmake boost)
+optdepends=(gst-plugins-good
+ gst-plugins-bad
+ gst-plugins-ugly)
+provides=(strawberry)
+conflicts=(strawberry strawberry-full-git)
+source=("${pkgname}::git+https://github.com/jonaski/strawberry.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ install -d strawberry-build
+}
+
+build() {
+ cd "${srcdir}/${pkgname}/strawberry-build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/strawberry-build"
+ make DESTDIR="${pkgdir}" install
+}