summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2016-04-08 13:40:25 -0400
committerAndy Kluger2016-04-08 13:40:25 -0400
commitb2ecf6934c78588254309cf5bd8e457035541074 (patch)
tree1797edf18c48be00d5cf55d9579bfe1859a66e24
downloadaur-b2ecf6934c78588254309cf5bd8e457035541074.tar.gz
new aur, finally
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..053d9488b7e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = stream_unrar-git
+ pkgdesc = Start extracting multi-part rar archives as soon as the first part is available
+ pkgver = 20140208.2a85bb8
+ pkgrel = 1
+ url = https://github.com/vlovich/stream-unrar
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ provides = stream_unrar
+ provides = libunrar=4.0.7
+ conflicts = stream_unrar
+ conflicts = libunrar
+ source = git+https://github.com/vlovich/stream-unrar.git
+ md5sums = SKIP
+
+pkgname = stream_unrar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2e235ddedae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Frederik Alkærsig (FALKER, FALK) <havnelisten@gmail.com>
+# Contributor: Andy Kluger <andykluger@gmail.com>
+pkgname=stream_unrar-git
+pkgver=20140208.2a85bb8
+pkgrel=1
+pkgdesc='Start extracting multi-part rar archives as soon as the first part is available'
+arch=('i686' 'x86_64')
+license=('GPL2')
+# depends=()
+conflicts=('stream_unrar' 'libunrar')
+provides=('stream_unrar' 'libunrar=4.0.7')
+makedepends=('git' 'cmake')
+source=('git+https://github.com/vlovich/stream-unrar.git')
+md5sums=('SKIP')
+url='https://github.com/vlovich/stream-unrar'
+
+pkgver() {
+ cd "${srcdir}/stream-unrar"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+# prepare() {}
+
+build() {
+ cd "${srcdir}/stream-unrar"
+ cmake .
+ make
+}
+
+package() {
+ cd "${srcdir}/stream-unrar"
+ install -D kde_service_menu/stream-unrar.desktop ${pkgdir}/usr/share/kservices5/ServiceMenus/stream-unrar.desktop
+ install -D stream-unrar ${pkgdir}/usr/bin/stream-unrar
+ install -D 3rd_party/unrar-4.0.7/libunrar.so ${pkgdir}/usr/lib/unrar.so
+}