diff options
author | zxp19821005 | 2023-12-13 10:58:12 +0800 |
---|---|---|
committer | zxp19821005 | 2023-12-13 10:58:12 +0800 |
commit | b3c10454996b09a01878db25590eead3fc9f61fe (patch) | |
tree | b04736058ac3d85ed42eee68b1bbef6bd1c3ae27 | |
parent | cd01509bde053667b0629b9efebe83125a770168 (diff) | |
download | aur-b3c10454996b09a01878db25590eead3fc9f61fe.tar.gz |
fix errors
-rw-r--r-- | .SRCINFO | 5 | ||||
-rw-r--r-- | PKGBUILD | 16 | ||||
-rw-r--r-- | streambop.sh | 17 |
3 files changed, 23 insertions, 15 deletions
@@ -1,18 +1,17 @@ pkgbase = streambop-bin pkgdesc = A software that allows you to play music on your livestreams, credit currently playing music, avoid legal issues, allow audio mixing, customizability and more.. pkgver = 1.6.1 - pkgrel = 1 + pkgrel = 2 url = https://github.com/snaildos/StreamBop arch = x86_64 license = GPL3 makedepends = squashfuse - depends = bash depends = electron25 provides = streambop=1.6.1 conflicts = streambop source = streambop-1.6.1.AppImage::https://github.com/snaildos/StreamBop/releases/download/v1.6.1/StreamBop-1.6.1.AppImage source = streambop.sh sha256sums = b6c79450f75a8802f0b51744d118437dcab72bb05af3fa36414a1c29ede6387f - sha256sums = e77cac9cf6e549364aec784eed810d85a57a9db611181b943d26164459cfd31b + sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84 pkgname = streambop-bin @@ -2,7 +2,8 @@ pkgname=streambop-bin _pkgname=StreamBop pkgver=1.6.1 -pkgrel=1 +_electronversion=25 +pkgrel=2 pkgdesc="A software that allows you to play music on your livestreams, credit currently playing music, avoid legal issues, allow audio mixing, customizability and more.." arch=('x86_64') url="https://github.com/snaildos/StreamBop" @@ -10,16 +11,21 @@ license=('GPL3') provides=("${pkgname%-bin}=${pkgver}") conflicts=("${pkgname%-bin}") depends=( - 'bash' - 'electron25' + "electron${_electronversion}" +) +makedepends=( + 'squashfuse' ) -makedepends=('squashfuse') source=( "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.AppImage" "${pkgname%-bin}.sh") sha256sums=('b6c79450f75a8802f0b51744d118437dcab72bb05af3fa36414a1c29ede6387f' - 'e77cac9cf6e549364aec784eed810d85a57a9db611181b943d26164459cfd31b') + '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84') build() { + sed -e "s|@electronversion@|${_electronversion}|" \ + -e "s|@appname@|${pkgname%-bin}|g" \ + -e "s|@appasar@|app.asar|g" \ + -i "${srcdir}/${pkgname%-bin}.sh" chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \; diff --git a/streambop.sh b/streambop.sh index fbddbe65f7e8..2ec4412e5c4f 100644 --- a/streambop.sh +++ b/streambop.sh @@ -1,11 +1,14 @@ #!/bin/bash -APPDIR="/usr/lib/streambop" -_ELECTRON=/usr/bin/electron25 -export PATH="${APPDIR}:${PATH}" -export LD_LIBRARY_PATH="${APPDIR}:${LD_LIBRARY_PATH}" -_ASAR="${APPDIR}/app.asar" +set -e +_APPDIR="/usr/lib/@appname@" +export PATH="${_APPDIR}:${PATH}" +export ELECTRON_IS_DEV=0 +export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}" +_ASAR="${_APPDIR}/@appasar@" if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then - exec ${_ELECTRON} ${_ASAR} "$@" + cd "${_APPDIR}" + exec electron@electronversion@ "${_ASAR}" "$@" else - exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@" + cd "${_APPDIR}" + exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" fi
\ No newline at end of file |