summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhexptr2020-07-25 23:25:58 +0100
committerhexptr2020-07-25 23:26:42 +0100
commit3a5a5fc4f3aab2329f2178c3ea7d1c463aa0212b (patch)
treeed8a78bb55b4ef3c468b4fe238ffb689f0d0b6a4
parentb15a179788b0231638fca9ce9d264977db7e9256 (diff)
downloadaur-3a5a5fc4f3aab2329f2178c3ea7d1c463aa0212b.tar.gz
Update; add udev rules
-rw-r--r--.SRCINFO6
-rw-r--r--60-streamdeck.rules4
-rw-r--r--PKGBUILD17
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c60de4527e50..a8257a7c1b4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = streamdeck-ui-git
pkgdesc = A Linux compatible UI for the Elgato Stream Deck
- pkgver = r102.96f2305
- pkgrel = 1
+ pkgver = r113.ce2156a
+ pkgrel = 2
url = https://timothycrosley.github.io/streamdeck-ui/
arch = any
license = MIT
@@ -15,7 +15,9 @@ pkgbase = streamdeck-ui-git
depends = python-elgato-streamdeck
provides = streamdeck-ui
source = git+https://github.com/timothycrosley/streamdeck-ui.git
+ source = 60-streamdeck.rules
sha512sums = SKIP
+ sha512sums = 79b03a68354f4642067cea9884a839c3869186165e4ad9a61dd60c865dc61c2dc392619a13767c4e4da34b34ec2988333f2f0f704f5a5d277f45216eb872d000
pkgname = streamdeck-ui-git
diff --git a/60-streamdeck.rules b/60-streamdeck.rules
new file mode 100644
index 000000000000..ed57de285315
--- /dev/null
+++ b/60-streamdeck.rules
@@ -0,0 +1,4 @@
+SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="0060", GROUP="users", MODE="0666"
+SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="0063", GROUP="users", MODE="0666"
+SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="006c", GROUP="users", MODE="0666"
+SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="006d", GROUP="users", MODE="0666"
diff --git a/PKGBUILD b/PKGBUILD
index cd1f904573a0..4767481dd1ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: hexptr <hexptr@protonmail.com>
pkgname=streamdeck-ui-git
_pkgname=streamdeck-ui
-pkgver=r102.96f2305
-pkgrel=1
+pkgver=r113.ce2156a
+pkgrel=2
pkgdesc="A Linux compatible UI for the Elgato Stream Deck"
arch=('any')
url="https://timothycrosley.github.io/streamdeck-ui/"
@@ -10,8 +10,10 @@ license=('MIT')
depends=('python-pillow' 'python-hidapi' 'pyside2' 'python-pynput' 'python-elgato-streamdeck')
makedepends=('git' 'python-dephell' 'python-setuptools')
provides=('streamdeck-ui')
-source=("git+https://github.com/timothycrosley/streamdeck-ui.git")
-sha512sums=('SKIP')
+source=("git+https://github.com/timothycrosley/streamdeck-ui.git"
+ "60-streamdeck.rules")
+sha512sums=('SKIP'
+ '79b03a68354f4642067cea9884a839c3869186165e4ad9a61dd60c865dc61c2dc392619a13767c4e4da34b34ec2988333f2f0f704f5a5d277f45216eb872d000')
pkgver() {
cd "$_pkgname"
@@ -19,16 +21,17 @@ pkgver() {
}
prepare() {
- cd "$_pkgname"
+ cd "$_pkgname"
dephell deps convert --from pyproject.toml --to setup.py
}
build() {
- cd "$_pkgname"
+ cd "$_pkgname"
python setup.py build
}
package() {
- cd "$_pkgname"
+ cd "$_pkgname"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 "$srcdir/60-streamdeck.rules" "${pkgdir}/usr/lib/udev/rules.d/60-streamdeck.rules"
}