summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-10-06 16:21:32 -0700
committerxiota2023-10-06 16:21:32 -0700
commit84f54001cab56ac61ce04b262ff267d475c15e18 (patch)
treeb2ba27d559405bec17819f478ea68212868e8ba4
parent365df449d73ae00143d6c78f16af21c159a7d448 (diff)
downloadaur-84f54001cab56ac61ce04b262ff267d475c15e18.tar.gz
3.1.0.r1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD33
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29941d29c743..722e2216d01f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = streamdeck-ui-git
pkgdesc = A Linux compatible UI for the Elgato Stream Deck
- pkgver = 3.0.1.r9.g9c7e67b
+ pkgver = 3.1.0.r1.ga3f3cf8
pkgrel = 1
url = https://github.com/streamdeck-linux-gui/streamdeck-linux-gui
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index fea61f6d5493..8b523efc5b5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Maintainer:
+# Maintainer: xiota / aur.chaotic.cx
# Contributor: fsyy <fossy2001 at web.de>
_pkgname="streamdeck-ui"
pkgname="$_pkgname-git"
-pkgver=3.0.1.r9.g9c7e67b
+pkgver=3.1.0.r1.ga3f3cf8
pkgrel=1
pkgdesc="A Linux compatible UI for the Elgato Stream Deck"
arch=('any')
-url="https://github.com/streamdeck-linux-gui/streamdeck-linux-gui"
+url="https://streamdeck-linux-gui.github.io/streamdeck-linux-gui/"
license=('MIT')
depends=(
'pyside6'
@@ -32,18 +32,24 @@ optdepends=(
'gnome-shell-extension-appindicator: tray icon support gnome-shell'
)
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+if [ x"$pkgver" != x"$_pkgver" ] ; then
+ url="https://github.com/streamdeck-linux-gui/streamdeck-linux-gui"
-source=(
- "$_pkgname"::"git+$url"
+ provides=("$_pkgname")
+ conflicts=("$_pkgname")
+
+ _pkgsrc="$_pkgname"
+ source=("$_pkgsrc"::"git+$url")
+ sha256sums=('SKIP')
+fi
+
+source+=(
"60-streamdeck.rules"
"elgato.png"
"streamdeck-ui.desktop"
"streamdeck.service"
)
-sha256sums=(
- 'SKIP'
+sha256sums+=(
'f91b76a71ee5253bcc3dff2a096fb7c2cc8ec4f510c7a9adc4df1f0967ea3dd3'
'03726bef65cec1a2ff4bb0241e021d112bf8b5a9a90ca0e3ebeba34358b281fe'
'03e288cca64bf0aa8f951b849bdace4ec27d20f4b3b1a24869e8f8fa20442c47'
@@ -51,17 +57,18 @@ sha256sums=(
)
pkgver() {
- cd "$_pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgsrc"
+ git describe --tag --exclude '*[a-z][a-z]*' \
+ | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname"
+ cd "$_pkgsrc"
DISABLE_CONAN=ON python -m build --wheel --no-isolation --skip-dependency-check
}
package() {
- cd "$_pkgname"
+ cd "$_pkgsrc"
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 "$srcdir/60-streamdeck.rules" -t "$pkgdir/usr/lib/udev/rules.d"