summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2018-06-06 20:02:56 +0200
committerJosip Ponjavic2018-06-06 20:02:56 +0200
commit65281dc9f3fbf90d8ce8d210f69b7d3481b8773d (patch)
treef70c80b35edcd3af2f31e583153c9c6b54d1a80a
parent98ddb149398f06ff25790f2462a2a64d441d94eb (diff)
downloadaur-65281dc9f3fbf90d8ce8d210f69b7d3481b8773d.tar.gz
bump: 0.13.0.r0.g97b04b89-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5c9df542dfc..aafecc724c6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = streamlink-git
pkgdesc = CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)
- pkgver = 0.12.1.r65.gc1489782
+ pkgver = 0.13.0.r0.g97b04b89
pkgrel = 1
url = https://streamlink.github.io/
arch = any
@@ -22,7 +22,7 @@ pkgbase = streamlink-git
optdepends = ffmpeg: Required to play streams that are made up of separate audio and video streams, eg. YouTube 1080p+
provides = streamlink
conflicts = streamlink
- source = git+https://github.com/streamlink/streamlink.git
+ source = streamlink::git+https://github.com/streamlink/streamlink.git
sha512sums = SKIP
pkgname = streamlink-git
diff --git a/PKGBUILD b/PKGBUILD
index 1ad9678f6534..4f03292b976a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _use_pycrypto="no"
_use_pycountry="no"
pkgname=streamlink-git
-pkgver=0.12.1.r65.gc1489782
+pkgver=0.13.0.r0.g97b04b89
pkgrel=1
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
@@ -28,18 +28,18 @@ depends+=("python-"{isodate,pysocks,requests,websocket-client} 'rtmpdump')
checkdepends=("python-"{freezegun,mock,pytest,requests-mock})
makedepends=('git' 'python-recommonmark')
optdepends=('ffmpeg: Required to play streams that are made up of separate audio and video streams, eg. YouTube 1080p+')
-provides=('streamlink')
-conflicts+=('streamlink')
-source=('git+https://github.com/streamlink/streamlink.git')
+provides=("${pkgname%-*}")
+conflicts+=("${pkgname%-*}")
+source=("${pkgname%-*}::git+https://github.com/streamlink/streamlink.git")
sha512sums=('SKIP')
pkgver() {
- cd streamlink
+ cd "${pkgname%-*}"
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd streamlink
+ cd "${pkgname%-*}"
if [ "$_use_pycrypto" = "yes" ]; then
msg "Using pycrypto..."
export STREAMLINK_USE_PYCRYPTO="true"
@@ -52,12 +52,12 @@ build() {
}
check() {
- cd streamlink
+ cd "${pkgname%-*}"
python setup.py test || warning "Tests failed"
}
package() {
- cd streamlink
+ cd "${pkgname%-*}"
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 build/sphinx/man/streamlink.1 \
"$pkgdir/usr/share/man/man1/streamlink.1"