summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2016-11-25 00:22:24 +0100
committerJosip Ponjavic2016-11-25 00:22:24 +0100
commitf4a35e39a0cd70f48b16a4e9e9010fd592f6a24a (patch)
treed20d567cf32df9aca3f258b34e4cf84b14cddf25
parentd8c8305fc24a89b1842867926823681efbabc10b (diff)
downloadaur-f4a35e39a0cd70f48b16a4e9e9010fd592f6a24a.tar.gz
temporary fix to build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0242d363373..ffcf840bd71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = streamlink-git
pkgdesc = CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)
- pkgver = 0.1.0.r15.ga6c70f7
+ pkgver = 0.1.0.r20.g2808eb6
pkgrel = 1
url = https://streamlink.github.io/
arch = any
@@ -8,7 +8,7 @@ pkgbase = streamlink-git
makedepends = git
makedepends = python-sphinx
depends = python-pycryptodome
- depends = python-requests<2.12
+ depends = python-requests
depends = python-setuptools
depends = rtmpdump
optdepends = python-librtmp: Required by the ustreamtv plugin to be able to use non-mobile streams.
diff --git a/PKGBUILD b/PKGBUILD
index 6009b0f6bfd..27fcf5a32a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=streamlink-git
-pkgver=0.1.0.r15.ga6c70f7
+pkgver=0.1.0.r20.g2808eb6
pkgrel=1
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
url='https://streamlink.github.io/'
license=('BSD')
-depends=('python-pycryptodome' 'python-requests<2.12' 'python-setuptools' 'rtmpdump')
+depends=('python-pycryptodome' 'python-requests' 'python-setuptools' 'rtmpdump')
makedepends=('git' 'python-sphinx')
optdepends=('python-librtmp: Required by the ustreamtv plugin to be able to use non-mobile streams.')
provides=('streamlink')
@@ -22,6 +22,7 @@ pkgver() {
build() {
cd streamlink
+ sed -i 's/requests>=1.0,<2.12.0/requests>=1.0,<3.0/' setup.py
python setup.py build_sphinx -b man
}