summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbastimeyer2017-01-01 09:58:11 +0100
committerbastimeyer2017-01-01 09:58:11 +0100
commit0419f237564e3dc6cd7954eec80b4e4e6545c058 (patch)
tree0c495843189a220531ee0cb9d93998e22e5b2d9c
parent8f07524b1edee21ba6403fd551b456cd51df4514 (diff)
downloadaur-0419f237564e3dc6cd7954eec80b4e4e6545c058.tar.gz
v1.1.0
- Move streamlink to optdepends - Include livestreamer in optdepends - Update LICENSE - Replace md5 hashes with sha256
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE2
-rw-r--r--PKGBUILD13
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf22ef3748a6..364cb4a7fa16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = streamlink-twitch-gui
pkgdesc = A multi platform Twitch.tv browser for Streamlink
- pkgver = 1.0.1
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/streamlink/streamlink-twitch-gui
install = streamlink-twitch-gui.install
@@ -16,15 +16,17 @@ pkgbase = streamlink-twitch-gui
depends = nss
depends = streamlink
depends = xdg-utils
+ optdepends = streamlink
+ optdepends = livestreamer
provides = streamlink-twitch-gui
conflicts = streamlink-twitch-gui-git
options = !strip
source = https://raw.githubusercontent.com/streamlink/streamlink-twitch-gui/master/LICENSE
- md5sums = 0b62e5d2cf76f19fea17c82c1a56c583
- source_i686 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.0.1/streamlink-twitch-gui-v1.0.1-linux32.tar.gz
- md5sums_i686 = 1ff7d200df8c33666f260ead565c7d2d
- source_x86_64 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.0.1/streamlink-twitch-gui-v1.0.1-linux64.tar.gz
- md5sums_x86_64 = f2fa60b4ccfd5f4cf50573d7dd78d0c2
+ sha256sums = a3f70e2c1fabdc05bde59f20d77863362d127b1c231c735a0422fa079c40415f
+ source_i686 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.1.0/streamlink-twitch-gui-v1.1.0-linux32.tar.gz
+ sha256sums_i686 = b2f4908145a1b49e0a19b6bf2fc1fd973e02c27cb52c1f9baf772ae16a56420b
+ source_x86_64 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.1.0/streamlink-twitch-gui-v1.1.0-linux64.tar.gz
+ sha256sums_x86_64 = 896d32bed62b6e910b0fd562cf96af8b076036af5523b757fa9845c983ca2d59
pkgname = streamlink-twitch-gui
diff --git a/LICENSE b/LICENSE
index 7d7264cb5cd1..c6ae6e45c6f5 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,6 +1,6 @@
The MIT License (MIT)
-Copyright (c) 2013-2016 Sebastian Meyer
+Copyright (c) 2013-2017 Sebastian Meyer
Permission is hereby granted, free of charge, to any person obtaining a copy of
this software and associated documentation files (the "Software"), to deal in
diff --git a/PKGBUILD b/PKGBUILD
index 9bfcbd22e534..65fc9b307bfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ben Fox-Moore <ben.foxmoore@gmail.com>
# Co-Maintainer: Sebastian Meyer <mail@bastimeyer.de>
pkgname=streamlink-twitch-gui
-pkgver=1.0.1
+pkgver=1.1.0
pkgrel=1
pkgdesc="A multi platform Twitch.tv browser for Streamlink"
arch=("i686" "x86_64")
@@ -15,9 +15,12 @@ depends=(
"libnotify"
"libxtst"
"nss"
- "streamlink"
"xdg-utils"
)
+optdepends=(
+ "streamlink: streaming provider"
+ "livestreamer: streaming provider (deprecated)"
+)
provides=("streamlink-twitch-gui")
conflicts=("streamlink-twitch-gui-git")
options=(!strip)
@@ -25,9 +28,9 @@ install=$pkgname.install
source=("https://raw.githubusercontent.com/streamlink/streamlink-twitch-gui/master/LICENSE")
source_i686=("https://github.com/streamlink/streamlink-twitch-gui/releases/download/v$pkgver/streamlink-twitch-gui-v$pkgver-linux32.tar.gz")
source_x86_64=("https://github.com/streamlink/streamlink-twitch-gui/releases/download/v$pkgver/streamlink-twitch-gui-v$pkgver-linux64.tar.gz")
-md5sums=('0b62e5d2cf76f19fea17c82c1a56c583')
-md5sums_i686=('1ff7d200df8c33666f260ead565c7d2d')
-md5sums_x86_64=('f2fa60b4ccfd5f4cf50573d7dd78d0c2')
+sha256sums=('a3f70e2c1fabdc05bde59f20d77863362d127b1c231c735a0422fa079c40415f')
+sha256sums_i686=('b2f4908145a1b49e0a19b6bf2fc1fd973e02c27cb52c1f9baf772ae16a56420b')
+sha256sums_x86_64=('896d32bed62b6e910b0fd562cf96af8b076036af5523b757fa9845c983ca2d59')
package() {
cd "$srcdir/$pkgname"