summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbastimeyer2023-01-06 00:15:06 +0100
committerbastimeyer2023-01-06 00:15:06 +0100
commit97f227d1e550b5ac1517365417ac4d7a892f1a72 (patch)
tree4f6a60801deb537070a0a671456b4f8b1f8f845f
parentb43ddd22c35c458aad728af049ddbb8379a8f292 (diff)
downloadaur-97f227d1e550b5ac1517365417ac4d7a892f1a72.tar.gz
Add NODE_OPTIONS=--openssl-legacy-provider
and temporarily fix an issue with build-dependencies of the v2.2.0 release which are relying on MD4 when creating a local file cache while transpiling JS code. MD4 is unsupported since OpenSSL3.
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0aedc34ec64e..6967c73b8688 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,6 +39,9 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ # temporarily fix broken build-dependencies relying on md4 hashes, which are unsupported on OpenSSL3
+ # https://github.com/streamlink/streamlink-twitch-gui/issues/944
+ NODE_OPTIONS=--openssl-legacy-provider \
yarn run grunt clean:tmp_prod webpack:prod "compile:${_arch}"
}