summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Fox-Moore2016-12-05 01:58:18 +0100
committerBen Fox-Moore2016-12-05 01:58:18 +0100
commitcc1e6a356110af3b155d221348b5f0e34a22b6f6 (patch)
tree161f7e20b79b503373ed622c381006ddae8b4a4a
downloadaur-cc1e6a356110af3b155d221348b5f0e34a22b6f6.tar.gz
Package renamed from livestreamer-twitch-gui, and version bumped to 1.0.0
-rw-r--r--.SRCINFO32
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD47
-rw-r--r--streamlink-twitch-gui.install15
4 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7081c4bf91da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+# Generated by mksrcinfo v8
+# Mon Dec 5 00:50:43 UTC 2016
+pkgbase = streamlink-twitch-gui
+ pkgdesc = A multi platform Twitch.tv browser for Streamlink
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/streamlink/streamlink-twitch-gui
+ install = streamlink-twitch-gui.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = alsa-lib
+ depends = gconf
+ depends = glib2
+ depends = gtk2
+ depends = libnotify
+ depends = libxtst
+ depends = nss
+ depends = streamlink
+ depends = xdg-utils
+ provides = streamlink-twitch-gui
+ conflicts = streamlink-twitch-gui-git
+ options = !strip
+ source = https://raw.githubusercontent.com/streamlink/streamlink-twitch-gui/master/LICENSE
+ md5sums = 0b62e5d2cf76f19fea17c82c1a56c583
+ source_i686 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.0.0/streamlink-twitch-gui-v1.0.0-linux32.tar.gz
+ md5sums_i686 = 2ed3e4686af9de4c0b0ba85498595f34
+ source_x86_64 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.0.0/streamlink-twitch-gui-v1.0.0-linux64.tar.gz
+ md5sums_x86_64 = 5c5a6c7ee710752e9b2938ed9b1f1c30
+
+pkgname = streamlink-twitch-gui
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..7d7264cb5cd1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+The MIT License (MIT)
+
+Copyright (c) 2013-2016 Sebastian Meyer
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
+FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
+COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ec0da090f78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Ben Fox-Moore <ben.foxmoore@gmail.com>
+pkgname=streamlink-twitch-gui
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A multi platform Twitch.tv browser for Streamlink"
+arch=("i686" "x86_64")
+url="https://github.com/streamlink/streamlink-twitch-gui"
+license=("MIT")
+depends=(
+ "alsa-lib"
+ "gconf"
+ "glib2"
+ "gtk2"
+ "libnotify"
+ "libxtst"
+ "nss"
+ "streamlink"
+ "xdg-utils"
+)
+provides=("streamlink-twitch-gui")
+conflicts=("streamlink-twitch-gui-git")
+options=(!strip)
+install=$pkgname.install
+source=("https://raw.githubusercontent.com/streamlink/streamlink-twitch-gui/master/LICENSE")
+source_i686=("https://github.com/streamlink/streamlink-twitch-gui/releases/download/v$pkgver/streamlink-twitch-gui-v$pkgver-linux32.tar.gz")
+source_x86_64=("https://github.com/streamlink/streamlink-twitch-gui/releases/download/v$pkgver/streamlink-twitch-gui-v$pkgver-linux64.tar.gz")
+md5sums=('0b62e5d2cf76f19fea17c82c1a56c583')
+md5sums_i686=('2ed3e4686af9de4c0b0ba85498595f34')
+md5sums_x86_64=('5c5a6c7ee710752e9b2938ed9b1f1c30')
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -d "$pkgdir/opt/$pkgname"
+ install -d "$pkgdir/usr/bin/"
+
+ sed -i "s:Exec=\$HERE/start.sh:Exec=/usr/bin/$pkgname:g" add-menuitem.sh
+ sed -i "s:CHECKNEWVERSIONS=true:CHECKNEWVERSIONS=false:g" start.sh
+
+ cp -R * "$pkgdir/opt/$pkgname"
+
+ ln -s "/opt/$pkgname/start.sh" "$pkgdir/usr/bin/$pkgname"
+ ln -s "/usr/lib/libudev.so" "$pkgdir/opt/$pkgname/libudev.so.0"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ cp "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}
diff --git a/streamlink-twitch-gui.install b/streamlink-twitch-gui.install
new file mode 100644
index 000000000000..246c87ce9f1d
--- /dev/null
+++ b/streamlink-twitch-gui.install
@@ -0,0 +1,15 @@
+post_install() {
+ /opt/streamlink-twitch-gui/add-menuitem.sh
+}
+
+pre_remove() {
+ /opt/streamlink-twitch-gui/remove-menuitem.sh
+}
+
+pre_upgrade() {
+ /opt/streamlink-twitch-gui/remove-menuitem.sh
+}
+
+post_upgrade() {
+ /opt/streamlink-twitch-gui/add-menuitem.sh
+}