summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbastimeyer2021-10-26 03:33:20 +0200
committerbastimeyer2021-10-26 03:33:20 +0200
commit1fa3a27303c87493e4cfee1f8a01cddb0b980e8e (patch)
tree3819aae3a87d46ffff1fe3001d279d68fde0122e
parentef38f1507e7b45d9c8f850385dedaf27a500f4a3 (diff)
downloadaur-1fa3a27303c87493e4cfee1f8a01cddb0b980e8e.tar.gz
Rename package to streamlink-twitch-gui-bin
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD37
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d5cd99aa077..88f166395b97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = streamlink-twitch-gui
+pkgbase = streamlink-twitch-gui-bin
pkgdesc = A multi platform Twitch.tv browser for Streamlink
pkgver = 1.13.0
pkgrel = 1
@@ -10,11 +10,11 @@ pkgbase = streamlink-twitch-gui
depends = libxss
depends = nss
depends = streamlink
- conflicts = streamlink-twitch-gui-git
+ provides = streamlink-twitch-gui
options = !strip
source_i686 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.13.0/streamlink-twitch-gui-v1.13.0-linux32.tar.gz
sha256sums_i686 = e8c149d05103d0da91262d5e2dff2edb4badc77f3b7cd049d420f39de573ae8d
source_x86_64 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.13.0/streamlink-twitch-gui-v1.13.0-linux64.tar.gz
sha256sums_x86_64 = 5b3ea3d701428bb96bbc26edd5aeaaf29d1a60a9d20d3a990fd37617a74c98fb
-pkgname = streamlink-twitch-gui
+pkgname = streamlink-twitch-gui-bin
diff --git a/PKGBUILD b/PKGBUILD
index ed6749e45e7d..b8af6b11958e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,61 @@
# Maintainer: Sebastian Meyer <mail@bastimeyer.de>
-# Former maintainer: Ben Fox-Moore <ben.foxmoore@gmail.com>
-pkgname=streamlink-twitch-gui
+
+_pkgname=streamlink-twitch-gui
+pkgname="${_pkgname}-bin"
pkgver=1.13.0
pkgrel=1
pkgdesc="A multi platform Twitch.tv browser for Streamlink"
arch=("i686" "x86_64")
url="https://github.com/streamlink/streamlink-twitch-gui"
license=("MIT")
+provides=("${_pkgname}")
depends=("gtk3" "libxss" "nss" "streamlink")
-conflicts=("streamlink-twitch-gui-git")
options=(!strip)
-source_i686=("https://github.com/streamlink/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}-linux32.tar.gz")
-source_x86_64=("https://github.com/streamlink/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}-linux64.tar.gz")
+source_i686=("https://github.com/streamlink/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-linux32.tar.gz")
+source_x86_64=("https://github.com/streamlink/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-linux64.tar.gz")
sha256sums_i686=('e8c149d05103d0da91262d5e2dff2edb4badc77f3b7cd049d420f39de573ae8d')
sha256sums_x86_64=('5b3ea3d701428bb96bbc26edd5aeaaf29d1a60a9d20d3a990fd37617a74c98fb')
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${_pkgname}"
# set up package directories
install -d \
- "${pkgdir}/opt/${pkgname}/" \
+ "${pkgdir}/opt/${_pkgname}/" \
"${pkgdir}/usr/bin/" \
"${pkgdir}/usr/share/applications/"
# copy licenses
install -Dm644 \
- -t "${pkgdir}/usr/share/licenses/${pkgname}/" \
+ -t "${pkgdir}/usr/share/licenses/${_pkgname}/" \
"./LICENSE.txt" \
"./credits.html"
# copy appstream metainfo
install -Dm644 \
-t "${pkgdir}/usr/share/metainfo/" \
- "./${pkgname}.appdata.xml"
+ "./${_pkgname}.appdata.xml"
# copy application content and remove unneeded files and dirs
- cp -a "./" "${pkgdir}/opt/${pkgname}/"
- rm -r "${pkgdir}/opt/${pkgname}/"{{add,remove}-menuitem.sh,LICENSE.txt,credits.html,"${pkgname}.appdata.xml",icons/}
+ cp -a ./ "${pkgdir}/opt/${_pkgname}/"
+ rm -r "${pkgdir}/opt/${_pkgname}/"{{add,remove}-menuitem.sh,LICENSE.txt,credits.html,"${_pkgname}.appdata.xml",icons/}
# create custom start script and disable version check
- cat > "${pkgdir}/usr/bin/${pkgname}" <<-EOF
+ cat > "${pkgdir}/usr/bin/${_pkgname}" <<-EOF
#!/usr/bin/env bash
- /opt/${pkgname}/${pkgname} "\$@" --no-version-check
+ /opt/${_pkgname}/${_pkgname} "\$@" --no-version-check
EOF
- chmod +x "${pkgdir}/usr/bin/${pkgname}"
+ chmod +x "${pkgdir}/usr/bin/${_pkgname}"
# copy icons
for res in 16 32 48 64 128 256; do
install -Dm644 \
"./icons/icon-${res}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${pkgname}.png"
+ "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${_pkgname}.png"
done
# create menu shortcut
- cat > "${pkgdir}/usr/share/applications/${pkgname}.desktop" <<-EOF
+ cat > "${pkgdir}/usr/share/applications/${_pkgname}.desktop" <<-EOF
[Desktop Entry]
Type=Application
Name=Streamlink Twitch GUI
@@ -62,7 +63,7 @@ package() {
Comment=Browse Twitch.tv and watch streams in your videoplayer of choice
Keywords=streamlink;twitch;streaming;
Categories=AudioVideo;Network;
- Exec=/usr/bin/${pkgname}
- Icon=${pkgname}
+ Exec=/usr/bin/${_pkgname}
+ Icon=${_pkgname}
EOF
}