summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbastimeyer2019-12-03 18:11:00 +0100
committerbastimeyer2019-12-03 18:11:00 +0100
commit46538b9ff404121780565eeedc8c39bad2d4f6e0 (patch)
tree39a287979796803a333abe6c55781b6cafcffc4d
parent63714033a94b176b6e2c10a04f3e78894b23a649 (diff)
downloadaur-46538b9ff404121780565eeedc8c39bad2d4f6e0.tar.gz
Fix dependencies and remove make dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 5 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 898915ab8fdf..4012401623a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,12 +6,8 @@ pkgbase = streamlink-twitch-gui
arch = i686
arch = x86_64
license = MIT
- makedepends = rsync
- depends = alsa-lib
- depends = gconf
- depends = glib2
depends = gtk3
- depends = libxtst
+ depends = libxss
depends = nss
depends = streamlink
provides = streamlink-twitch-gui
diff --git a/PKGBUILD b/PKGBUILD
index 1f6ea749fa99..5a00ec3b1ad2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,18 +7,7 @@ pkgdesc="A multi platform Twitch.tv browser for Streamlink"
arch=("i686" "x86_64")
url="https://github.com/streamlink/streamlink-twitch-gui"
license=("MIT")
-depends=(
- "alsa-lib"
- "gconf"
- "glib2"
- "gtk3"
- "libxtst"
- "nss"
- "streamlink"
-)
-makedepends=(
- "rsync"
-)
+depends=("gtk3" "libxss" "nss" "streamlink")
provides=("streamlink-twitch-gui")
conflicts=("streamlink-twitch-gui-git")
options=(!strip)
@@ -44,15 +33,9 @@ package() {
"${srcdir}/LICENSE" \
"./credits.html"
- # copy application content and ignore certain files and dirs
- rsync -a \
- --exclude "start.sh" \
- --exclude "add-menuitem.sh" \
- --exclude "remove-menuitem.sh" \
- --exclude "credits.html" \
- --exclude "icons" \
- "./" \
- "${pkgdir}/opt/${pkgname}/"
+ # copy application content and remove unneeded files and dirs
+ cp -a "./" "${pkgdir}/opt/${pkgname}/"
+ rm -r "${pkgdir}/opt/${pkgname}/"{{add,remove}-menuitem.sh,credits.html,icons/}
# create custom start script and disable version check
cat > "${pkgdir}/usr/bin/${pkgname}" <<-EOF