summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbastimeyer2020-12-22 12:14:39 +0100
committerbastimeyer2020-12-22 12:14:39 +0100
commit7840de35d56d7becddbb240889b9f84afacc3ccb (patch)
tree9e3c1a69c086b23fc5a8c27b5b2778264e061c6f
parent21eff43c68c117cbe050adf577455e46287f8aad (diff)
downloadaur-7840de35d56d7becddbb240889b9f84afacc3ccb.tar.gz
v1.11.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d8ad2123186..9b68ce3661bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = streamlink-twitch-gui
pkgdesc = A multi platform Twitch.tv browser for Streamlink
- pkgver = 1.10.0
+ pkgver = 1.11.0
pkgrel = 1
url = https://github.com/streamlink/streamlink-twitch-gui
arch = i686
@@ -12,10 +12,10 @@ pkgbase = streamlink-twitch-gui
depends = streamlink
conflicts = streamlink-twitch-gui-git
options = !strip
- source_i686 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.10.0/streamlink-twitch-gui-v1.10.0-linux32.tar.gz
- sha256sums_i686 = 427859bf9c8f7cff7a1054043d5ea425987b5878887c1d1ed8a6229261019cdf
- source_x86_64 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.10.0/streamlink-twitch-gui-v1.10.0-linux64.tar.gz
- sha256sums_x86_64 = 02decf79fa0481e291b8fddca1136b6d3a85d0197749de7b4dff5d22fffa499f
+ source_i686 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.11.0/streamlink-twitch-gui-v1.11.0-linux32.tar.gz
+ sha256sums_i686 = fee46e7ef9e4dfef77375775799546f4dce2e6c5ba45e2f156fcf0521c86d569
+ source_x86_64 = https://github.com/streamlink/streamlink-twitch-gui/releases/download/v1.11.0/streamlink-twitch-gui-v1.11.0-linux64.tar.gz
+ sha256sums_x86_64 = 3eb560af67a98322eab23985dbd46348a9594e50e6a2626fdeedeeade2b72679
pkgname = streamlink-twitch-gui
diff --git a/PKGBUILD b/PKGBUILD
index f29655e1e105..c87a09fb09b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastian Meyer <mail@bastimeyer.de>
# Former maintainer: Ben Fox-Moore <ben.foxmoore@gmail.com>
pkgname=streamlink-twitch-gui
-pkgver=1.10.0
+pkgver=1.11.0
pkgrel=1
pkgdesc="A multi platform Twitch.tv browser for Streamlink"
arch=("i686" "x86_64")
@@ -12,8 +12,8 @@ conflicts=("streamlink-twitch-gui-git")
options=(!strip)
source_i686=("https://github.com/streamlink/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}-linux32.tar.gz")
source_x86_64=("https://github.com/streamlink/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}-linux64.tar.gz")
-sha256sums_i686=('427859bf9c8f7cff7a1054043d5ea425987b5878887c1d1ed8a6229261019cdf')
-sha256sums_x86_64=('02decf79fa0481e291b8fddca1136b6d3a85d0197749de7b4dff5d22fffa499f')
+sha256sums_i686=('fee46e7ef9e4dfef77375775799546f4dce2e6c5ba45e2f156fcf0521c86d569')
+sha256sums_x86_64=('3eb560af67a98322eab23985dbd46348a9594e50e6a2626fdeedeeade2b72679')
package() {
cd "${srcdir}/${pkgname}"
@@ -30,9 +30,14 @@ package() {
"./LICENSE.txt" \
"./credits.html"
+ # copy appstream metainfo
+ install -Dm644 \
+ -t "${pkgdir}/usr/share/metainfo/" \
+ "./${pkgname}.appdata.xml"
+
# copy application content and remove unneeded files and dirs
cp -a "./" "${pkgdir}/opt/${pkgname}/"
- rm -r "${pkgdir}/opt/${pkgname}/"{{add,remove}-menuitem.sh,LICENSE.txt,credits.html,icons/}
+ rm -r "${pkgdir}/opt/${pkgname}/"{{add,remove}-menuitem.sh,LICENSE.txt,credits.html,"${pkgname}.appdata.xml",icons/}
# create custom start script and disable version check
cat > "${pkgdir}/usr/bin/${pkgname}" <<-EOF