summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Broda2018-03-02 20:00:17 +0100
committerRobin Broda2018-03-02 20:00:17 +0100
commit825da45fe9a9d60dcb29238ce621d61f7168de65 (patch)
tree95954f1b2146b1a8ce6683276364cf1841a61036
parente5376ffcef3cbf7d329788c062ba360afeffe617 (diff)
downloadaur-825da45fe9a9d60dcb29238ce621d61f7168de65.tar.gz
Add patch adding support for custom CFLAGS & LDFLAGS
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da1f1c6b6b86..b3a56c9c1a84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,9 @@ pkgbase = streem-git
provides = streem
conflicts = streem
source = git+https://github.com/matz/streem.git
+ source = streem-git-164.patch::https://github.com/matz/streem/pull/164.patch
md5sums = SKIP
+ md5sums = d285857bd0804471aa6560ccf4f2e295
pkgname = streem-git
diff --git a/PKGBUILD b/PKGBUILD
index 8be7d184a46d..71eb7d33aaf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,22 @@ provides=('streem')
conflicts=('streem')
depends=('glibc')
makedepends=('git')
-source=('git+https://github.com/matz/streem.git')
-md5sums=('SKIP')
+source=('git+https://github.com/matz/streem.git'
+ "${pkgname}-164.patch::https://github.com/matz/streem/pull/164.patch")
+md5sums=('SKIP'
+ 'd285857bd0804471aa6560ccf4f2e295')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${_pkgname}"
+
+ patch src/Makefile "${srcdir}/${pkgname}-164.patch"
+}
+
build() {
cd "${_pkgname}"