summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-04-01 12:21:42 +0000
committerDaniel Bermond2021-04-01 12:21:42 +0000
commit6ba14c2c7a4c421265730360a012e2456f9098b8 (patch)
treef0c0fe88691d4f5b5be0db5a6a12c16ecb3acf39
parentaefc745ac2cd251d9cb1fe2456d162fc14f52b84 (diff)
downloadaur-6ba14c2c7a4c421265730360a012e2456f9098b8.tar.gz
Update to version 4.4.135
-rw-r--r--.SRCINFO15
-rw-r--r--010-stremio-do-not-download-server-js.patch6
-rw-r--r--PKGBUILD10
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d69f98606f9..64a7dc49274d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = stremio
pkgdesc = A one-stop hub for video content aggregation (Movies, TV shows, series, live television or web channels)
- pkgver = 4.4.120
+ pkgver = 4.4.135
pkgrel = 1
url = https://www.stremio.com/
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = cmake
makedepends = librsvg
depends = mpv
depends = nodejs
@@ -17,20 +18,20 @@ pkgbase = stremio
depends = qt5-quickcontrols2
depends = qt5-translations
depends = qt5-webchannel
- source = git+https://github.com/Stremio/stremio-shell.git#tag=v4.4.120
+ source = git+https://github.com/Stremio/stremio-shell.git#tag=v4.4.135
source = git+https://github.com/Ivshti/libmpv.git
source = git+https://github.com/itay-grudev/SingleApplication.git
source = git+https://github.com/Ivshti/razerchroma.git
- source = stremio-4.4.120-server.js::https://dl.strem.io/four/v4.4.120/server.js
- source = stremio-4.4.120-stremio.asar::https://dl.strem.io/four/v4.4.120/stremio.asar
+ source = stremio-4.4.135-server.js::https://dl.strem.io/four/v4.4.135/server.js
+ source = stremio-4.4.135-stremio.asar::https://dl.strem.io/four/v4.4.135/stremio.asar
source = 010-stremio-do-not-download-server-js.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 241f5633528e9f19c84c7ca41266771c309e286d6d9393a99e0fbce2203a3caa
- sha256sums = d035141496ad41352490464c3fff6492d13fee146edb88afeefc15d07662e89e
- sha256sums = 7653fc2d0ddf20fa212f15648f5ceb1c0b7b5dd6902c31b20f9724cb1665ec74
+ sha256sums = 1560580101ec49d577f1840bc4215a584d01ee04a254826194b87f727f73bdc5
+ sha256sums = 03173f78f1de32522c3cad4f3db3e315b7d4f409795e30347aa13c617321ce39
+ sha256sums = d1702ebfa92b55c26331e26ff50b5240c8bf69b0edfd6b7b78ef2da257a864d4
pkgname = stremio
diff --git a/010-stremio-do-not-download-server-js.patch b/010-stremio-do-not-download-server-js.patch
index 0bca6f1057e7..6bd30b9ca250 100644
--- a/010-stremio-do-not-download-server-js.patch
+++ b/010-stremio-do-not-download-server-js.patch
@@ -9,16 +9,16 @@
install:
make -C ${BUILD_DIR} install
-@@ -27,14 +27,11 @@ icons:
+@@ -28,14 +28,11 @@ icons:
mkdir -p "$@"
cd "$@" && printf 16,22,24,32,64,128 | xargs -I^ -d, sh -c 'rsvg-convert ../images/stremio.svg -w ^ -o smartcode-stremio_^.png && rsvg-convert ../images/stremio_tray_white.svg -w ^ -o smartcode-stremio-tray_^.png'
-${SERVER_JS}:
-- wget "https://s3-eu-west-1.amazonaws.com/stremio-artifacts/four/v$(shell grep -hoP '^\s*VERSION\s*=\s*\K.*$$' stremio.pro)/server.js" -qO ${SERVER_JS} || rm ${SERVER_JS}
+- wget "https://s3-eu-west-1.amazonaws.com/stremio-artifacts/four/v$(shell ./dist-utils/common/get-version.sh)/server.js" -qO ${SERVER_JS} || rm ${SERVER_JS}
-
${STREMIO_BIN}:
mkdir -p ${BUILD_DIR}
- cd ${BUILD_DIR} && qmake PREFIX="${PREFIX}" ..
+ cd ${BUILD_DIR} && cmake -G"Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${PREFIX}" ..
make -j -C ${BUILD_DIR}
clean:
diff --git a/PKGBUILD b/PKGBUILD
index 291ce4ba2b94..3e1b18ace94d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=stremio
-pkgver=4.4.120
+pkgver=4.4.135
pkgrel=1
pkgdesc='A one-stop hub for video content aggregation (Movies, TV shows, series, live television or web channels)'
arch=('x86_64')
@@ -9,7 +9,7 @@ url='https://www.stremio.com/'
license=('GPL3')
depends=('mpv' 'nodejs' 'openssl' 'qt5-webengine' 'qt5-base' 'qt5-declarative'
'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-translations' 'qt5-webchannel')
-makedepends=('git' 'librsvg')
+makedepends=('git' 'cmake' 'librsvg')
source=("git+https://github.com/Stremio/stremio-shell.git#tag=v${pkgver}"
'git+https://github.com/Ivshti/libmpv.git'
'git+https://github.com/itay-grudev/SingleApplication.git'
@@ -21,9 +21,9 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '241f5633528e9f19c84c7ca41266771c309e286d6d9393a99e0fbce2203a3caa'
- 'd035141496ad41352490464c3fff6492d13fee146edb88afeefc15d07662e89e'
- '7653fc2d0ddf20fa212f15648f5ceb1c0b7b5dd6902c31b20f9724cb1665ec74')
+ '1560580101ec49d577f1840bc4215a584d01ee04a254826194b87f727f73bdc5'
+ '03173f78f1de32522c3cad4f3db3e315b7d4f409795e30347aa13c617321ce39'
+ 'd1702ebfa92b55c26331e26ff50b5240c8bf69b0edfd6b7b78ef2da257a864d4')
prepare() {
git -C stremio-shell submodule init