summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-06-01 18:10:23 +0000
committerDaniel Bermond2019-06-01 18:10:23 +0000
commitcabf656a9b8ce267c63dfd3a0eb609f9578a7448 (patch)
tree9a97ffe09887124e20daef583933593ec02665a0
downloadaur-cabf656a9b8ce267c63dfd3a0eb609f9578a7448.tar.gz
Initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD72
-rw-r--r--stremio-do-not-download-server-js.patch28
3 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a56ebd91bfad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = stremio
+ pkgdesc = A one-stop hub for video content aggregation (Movies, TV shows, series, live television or web channels)
+ pkgver = 4.4.52
+ pkgrel = 1
+ url = https://www.stremio.com/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = librsvg
+ depends = mpv
+ depends = qt5-webengine
+ depends = qt5-declarative
+ depends = qt5-webchannel
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = qt5-translations
+ depends = nodejs
+ source = git+https://github.com/Stremio/stremio-shell.git#tag=4.4.52
+ source = git+https://github.com/Ivshti/libmpv.git
+ source = git+http://github.com/itay-grudev/SingleApplication.git
+ source = git+https://github.com/Ivshti/razerchroma.git
+ source = stremio-4.4.52-server.js::https://dl.strem.io/four/v4.4.52/server.js
+ source = stremio-4.4.52-stremio.asar::https://dl.strem.io/four/v4.4.52/stremio.asar
+ source = stremio-do-not-download-server-js.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = a62f0cffd2cccb36aa9523d450403d6cd1950cc7e0b8f5c0ea03f34b08e66558
+ sha256sums = 9993faa94ab062c8eb22e9e7c6a113fdb6b024fd00eac5144ae3b1b8ce505b35
+ sha256sums = b1febe31374eaceefc1f869d574a00f7f5414eafa8b5d0a92a5f511078ba3add
+
+pkgname = stremio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f41381aac7de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+
+pkgname=stremio
+pkgver=4.4.52
+pkgrel=1
+pkgdesc='A one-stop hub for video content aggregation (Movies, TV shows, series, live television or web channels)'
+arch=('x86_64')
+url='https://www.stremio.com/'
+license=('GPL3')
+depends=('mpv' 'qt5-webengine' 'qt5-declarative' 'qt5-webchannel' 'qt5-quickcontrols'
+ 'qt5-quickcontrols2' 'qt5-translations' 'nodejs')
+makedepends=('git' 'librsvg')
+source=("git+https://github.com/Stremio/stremio-shell.git#tag=${pkgver}"
+ 'git+https://github.com/Ivshti/libmpv.git'
+ 'git+http://github.com/itay-grudev/SingleApplication.git'
+ 'git+https://github.com/Ivshti/razerchroma.git'
+ "stremio-${pkgver}-server.js"::"https://dl.strem.io/four/v${pkgver}/server.js"
+ "stremio-${pkgver}-stremio.asar"::"https://dl.strem.io/four/v${pkgver}/stremio.asar"
+ 'stremio-do-not-download-server-js.patch')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'a62f0cffd2cccb36aa9523d450403d6cd1950cc7e0b8f5c0ea03f34b08e66558'
+ '9993faa94ab062c8eb22e9e7c6a113fdb6b024fd00eac5144ae3b1b8ce505b35'
+ 'b1febe31374eaceefc1f869d574a00f7f5414eafa8b5d0a92a5f511078ba3add')
+
+prepare() {
+ cd stremio-shell
+
+ git submodule init
+ git config --local submodule.deps/libmpv.url "${srcdir}/libmpv"
+ git config --local submodule.deps/singleapplication.url "${srcdir}/SingleApplication"
+ git config --local submodule.deps/chroma.url "${srcdir}/razerchroma"
+ git submodule update
+
+ # do not download server.js during 'make'
+ ln -s "${srcdir}/stremio-${pkgver}-server.js" server.js
+ patch -Np1 -i "${srcdir}/stremio-do-not-download-server-js.patch"
+}
+
+build() {
+ cd stremio-shell
+
+ make -f release.makefile PREFIX="$pkgdir"
+}
+
+package() {
+ cd stremio-shell
+
+ make -f release.makefile PREFIX="$pkgdir" install
+
+ # streaming server files
+ install -D -m644 "${srcdir}/stremio-${pkgver}-server.js" "${pkgdir}/opt/stremio/server.js"
+ install -D -m644 "${srcdir}/stremio-${pkgver}-stremio.asar" "${pkgdir}/opt/stremio/stremio.asar"
+
+ # binary and desktop file
+ mkdir -p "${pkgdir}/usr/"{bin,share/applications}
+ ln -s ../../opt/stremio/stremio "${pkgdir}/usr/bin/stremio"
+ ln -s ../../../opt/stremio/smartcode-stremio.desktop "${pkgdir}/usr/share/applications/smartcode-stremio.desktop"
+
+ # icons
+ local _res
+ for _res in 16 22 24 32 64 128
+ do
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps"
+ ln -s ../../../../../../opt/stremio/icons/smartcode-stremio_${_res}.png \
+ "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/smartcode-stremio.png"
+ ln -s ../../../../../../opt/stremio/icons/smartcode-stremio-tray_${_res}.png \
+ "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/smartcode-stremio-tray.png"
+ done
+}
diff --git a/stremio-do-not-download-server-js.patch b/stremio-do-not-download-server-js.patch
new file mode 100644
index 000000000000..21705fd3be63
--- /dev/null
+++ b/stremio-do-not-download-server-js.patch
@@ -0,0 +1,28 @@
+diff -Naurp a/release.makefile b/release.makefile
+--- a/release.makefile 2019-06-01 17:55:19.000000000 +0000
++++ b/release.makefile 2019-06-01 17:58:39.254503016 +0000
+@@ -8,7 +8,7 @@ SERVER_JS := server.js
+
+ STREMIO_BIN := ${BUILD_DIR}/stremio
+
+-ALL: ${STREMIO_BIN} ${SERVER_JS} icons
++ALL: ${STREMIO_BIN} icons
+
+ install:
+ make -C ${BUILD_DIR} install
+@@ -24,14 +24,11 @@ icons:
+ mkdir -p "$@"
+ cd "$@" && printf 16,22,24,32,64,128 | xargs -I^ -d, sh -c 'rsvg-convert ../images/stremio.svg -w ^ -o smartcode-stremio_^.png && rsvg-convert ../images/stremio_tray_white.svg -w ^ -o smartcode-stremio-tray_^.png'
+
+-${SERVER_JS}:
+- wget "https://s3-eu-west-1.amazonaws.com/stremio-artifacts/four/master/server.js" -qO ${SERVER_JS} || rm ${SERVER_JS}
+-
+ ${STREMIO_BIN}:
+ mkdir -p ${BUILD_DIR}
+ cd ${BUILD_DIR} && qmake PREFIX="${PREFIX}" ..
+ make -j -C ${BUILD_DIR}
+
+ clean:
+- rm -rf ${BUILD_DIR} ${SERVER_JS} icons
++ rm -rf ${BUILD_DIR} icons
+