summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorenvolution2024-12-02 14:47:28 -0500
committerenvolution2024-12-02 14:47:28 -0500
commit72d8a04f0e73f45e076f303bdc9551c7a88a1ff7 (patch)
treeea027a48084663d9b7cbe907f5eaacb21b9ae769
downloadaur-72d8a04f0e73f45e076f303bdc9551c7a88a1ff7.tar.gz
initial
-rw-r--r--.SRCINFO28
-rw-r--r--.nvchecker.toml9
-rw-r--r--PKGBUILD45
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98ad8a31cac6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = stremio-git
+ pkgdesc = The next generation media center
+ pkgver = 4.4.168.qt6+r851+gf16a7b177
+ pkgrel = 1
+ url = https://www.stremio.com
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = wget
+ makedepends = qt5-tools
+ makedepends = librsvg
+ makedepends = cmake
+ depends = nodejs
+ depends = ffmpeg
+ depends = qt5-webengine
+ depends = qt5-webchannel
+ depends = qt5-declarative
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = qt5-translations
+ depends = mpv
+ depends = openssl
+ provides = stremio
+ conflicts = stremio
+ source = stremio::git+https://github.com/Stremio/stremio-shell.git#branch=master
+ md5sums = SKIP
+
+pkgname = stremio-git
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..d503f37e58b6
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,9 @@
+[stremio-git]
+source="github-graphql"
+github="stremio/stremio-shell"
+use_max_tag=true
+use_commit_number=true
+use_commit_hash=true
+from_pattern="-"
+to_pattern="."
+prefix="v"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..275ff132e56b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: envolution
+# Contributor: Vladimir Borisov <vladimir@stremio.com>
+# shellcheck shell=bash disable=SC2034,SC2154
+_pkgname=stremio
+pkgname=${_pkgname}-git
+pkgver=4.4.168.qt6+r851+gf16a7b177
+pkgrel=1
+pkgdesc="The next generation media center"
+arch=('x86_64')
+url="https://www.stremio.com"
+license=("MIT")
+depends=("nodejs" "ffmpeg" "qt5-webengine" "qt5-webchannel" "qt5-declarative" "qt5-quickcontrols" "qt5-quickcontrols2" "qt5-translations" "mpv" "openssl")
+makedepends=("git" "wget" "qt5-tools" "librsvg" "cmake")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Stremio/stremio-shell.git#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ _version=$(git tag --sort=-v:refname --list | head -n1 | cut -c2- | tr - .)
+ _commits=$(git rev-list --count HEAD)
+ _short_commit_hash=$(git rev-parse --short=9 HEAD)
+ echo "${_version}+r${_commits}+g${_short_commit_hash}"
+}
+prepare() {
+ git -C "${_pkgname}" submodule init
+ module_paths=($(grep -Po '(?<=path = ).*' "${_pkgname}/.gitmodules"))
+ for _submodule in module_paths; do
+ git -C "${_pkgname}" config --local "submodule.third_party/${_submodule}.url" "${_submodule}"
+ done
+ git -C "${_pkgname}" -c protocol.file.allow='always' submodule update
+}
+
+build() {
+ cd "${_pkgname}"
+ make -f release.makefile PREFIX="$pkgdir"
+}
+
+package() {
+ cd "${_pkgname}"
+ export PREFIX="$pkgdir"
+ make -f release.makefile install
+}
+# vim:set ts=2 sw=2 et: