summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrob2uk2017-07-16 01:35:58 +0200
committerrob2uk2017-07-16 01:35:58 +0200
commit837659b25b1f7c9e8c6c2825cbf585b9ea46a1c4 (patch)
tree52078f1530d3c41fa1c6d6ca398ff5e35cb45fbe
downloadaur-837659b25b1f7c9e8c6c2825cbf585b9ea46a1c4.tar.gz
move from stremio-bin to stremio-3
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD51
-rw-r--r--stremio.desktop9
-rw-r--r--stremio.install12
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c85c2aa51a3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = stremio-3
+ pkgdesc = Watch instantly all the video content you enjoy in one place.
+ pkgver = 3.6.5
+ pkgrel = 1
+ url = https://strem.io
+ install = stremio.install
+ arch = x86_64
+ license = custom
+ depends = ffmpeg
+ depends = gconf
+ depends = gtk2
+ depends = nss
+ source = https://strem.io/Stremio3.6.5.linux.tar.gz
+ source = https://strem.io/favicon-32x32.png
+ source = https://strem.io/favicon-96x96.png
+ source = stremio.desktop
+ sha512sums = dcf9deea7061c1103f5d441da4a4e8bf1e8aac1c55742878e45c7cbdcc6ecf7f3cee10082923bc3b4b22aa53c7779d97d59abb5fb23179e51d552f9da7e23646
+ sha512sums = 09c8fa78e477ee1919f7fa54265afb73528d51453dbf92ff0fab433792c0f9d33dd7dd826a60822a24c8027fdc2b383228cd58bb014519ee93fdb651d639d27d
+ sha512sums = 58fcbb09a2f8b8c83102b62449f5e483f6d6e60a764f728bd54ece313908622e32b27e3fa4909047ec54850b50322af5d1315abdb3740e60d75049faab913467
+ sha512sums = ae61a03eb6b1318e92d159de8e2c09a45b5fb4a665089aa11c3c99225978b0f864b84d6587b30fca96c559c2e8384db5140a41a23193790937ca654eb67821ff
+
+pkgname = stremio-3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67a180f0184c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Rob Lynn <rob22uk at gmail dot com>
+
+pkgname=stremio-3
+pkgver=3.6.5
+pkgrel=1
+pkgdesc="Watch instantly all the video content you enjoy in one place."
+arch=('x86_64')
+url="https://strem.io"
+depends=('ffmpeg' 'gconf' 'gtk2' 'nss')
+license=('custom')
+install=stremio.install
+source=("https://strem.io/Stremio${pkgver}.linux.tar.gz"
+ "https://strem.io/favicon-32x32.png"
+ "https://strem.io/favicon-96x96.png"
+ "stremio.desktop")
+sha512sums=('dcf9deea7061c1103f5d441da4a4e8bf1e8aac1c55742878e45c7cbdcc6ecf7f3cee10082923bc3b4b22aa53c7779d97d59abb5fb23179e51d552f9da7e23646'
+ '09c8fa78e477ee1919f7fa54265afb73528d51453dbf92ff0fab433792c0f9d33dd7dd826a60822a24c8027fdc2b383228cd58bb014519ee93fdb651d639d27d'
+ '58fcbb09a2f8b8c83102b62449f5e483f6d6e60a764f728bd54ece313908622e32b27e3fa4909047ec54850b50322af5d1315abdb3740e60d75049faab913467'
+ 'ae61a03eb6b1318e92d159de8e2c09a45b5fb4a665089aa11c3c99225978b0f864b84d6587b30fca96c559c2e8384db5140a41a23193790937ca654eb67821ff')
+
+prepare() {
+ sed -i "s#\$(dirname \$0)#/usr/share/stremio#" Stremio.sh
+}
+
+package() {
+ install -Dm644 stremio.desktop "$pkgdir/usr/share/applications/stremio.desktop"
+ install -Dm644 favicon-32x32.png "$pkgdir/usr/share/icons/hicolor/32x32/apps/stremio.png"
+ install -Dm644 favicon-96x96.png "$pkgdir/usr/share/icons/hicolor/96x96/apps/stremio.png"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/stremio/LICENSE"
+ install -Dm755 Stremio.sh "$pkgdir/usr/bin/stremio"
+
+ install -dm755 "$pkgdir/usr/share/stremio"
+
+ install -Dm644 content_shell.pak "$pkgdir/usr/share/stremio/"
+ install -Dm644 icudtl.dat "$pkgdir/usr/share/stremio/"
+ install -Dm644 libgcrypt.so.11 "$pkgdir/usr/share/stremio/"
+ install -Dm644 libnode.so "$pkgdir/usr/share/stremio/"
+ install -Dm644 libnotify.so.4 "$pkgdir/usr/share/stremio/"
+ install -Dm644 natives_blob.bin "$pkgdir/usr/share/stremio/"
+ install -Dm644 snapshot_blob.bin "$pkgdir/usr/share/stremio/"
+ install -Dm755 Stremio-runtime "$pkgdir/usr/share/stremio/"
+ install -Dm644 version "$pkgdir/usr/share/stremio/"
+
+ cp -pr locales "$pkgdir/usr/share/stremio/"
+ cp -pr resources "$pkgdir/usr/share/stremio/"
+ cp -pr WCjs "$pkgdir/usr/share/stremio/"
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/stremio.desktop b/stremio.desktop
new file mode 100644
index 000000000000..fe4a103c3aab
--- /dev/null
+++ b/stremio.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Stremio
+GenericName=Media Center
+Comment=Watch instantly all the video content you enjoy in one place
+Icon=stremio
+TryExec=stremio
+Exec=stremio
+Categories=AudioVideo;Video;Player;
diff --git a/stremio.install b/stremio.install
new file mode 100644
index 000000000000..5bca2b7ee8ee
--- /dev/null
+++ b/stremio.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}