summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Arms2022-04-03 20:51:54 +1000
committerLuke Arms2022-04-03 20:51:54 +1000
commite3fa2d87cbc34faf27a4ad43f957ade2abd32e4b (patch)
tree94c233ecefa3c0f7495969feff2085a7e5bfbcf2
parentb98da9f521ff9aa29612a0763939bf067c5e11c3 (diff)
downloadaur-e3fa2d87cbc34faf27a4ad43f957ade2abd32e4b.tar.gz
Update electron dependency
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b136c05260eb..453f5cfdfede 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stretchly
pkgdesc = The break time reminder app
pkgver = 1.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hovancik/stretchly/
arch = i686
arch = x86_64
@@ -21,8 +21,7 @@ pkgbase = stretchly
depends = libsecret
depends = libappindicator-gtk3
depends = libxcrypt-compat
- depends = electron>=17
- depends = electron<18
+ depends = electron17
conflicts = stretchly-bin
conflicts = stretchly-git
source = https://github.com/hovancik/stretchly/archive/v1.10.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 94a75cdb7863..8cc12e81c0a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=stretchly
pkgver=1.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="The break time reminder app"
arch=('i686' 'x86_64')
url="https://github.com/hovancik/stretchly/"
license=('BSD')
-depends=('gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'at-spi2-atk' 'util-linux-libs' 'libsecret' 'libappindicator-gtk3' 'libxcrypt-compat' 'electron>=17' 'electron<18')
+depends=('gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'at-spi2-atk' 'util-linux-libs' 'libsecret' 'libappindicator-gtk3' 'libxcrypt-compat' 'electron17')
makedepends=('git' 'nvm' 'jq' 'python')
conflicts=("${pkgname}-bin" "${pkgname}-git")
source=("https://github.com/hovancik/stretchly/archive/v${pkgver}.tar.gz")
@@ -59,8 +59,8 @@ build() {
./node_modules/.bin/electron-builder build \
--linux pacman \
--"${!CARCH}" \
- -c.electronDist=/usr/lib/electron \
- -c.electronVersion="$(</usr/lib/electron/version)"
+ -c.electronDist=/usr/lib/electron17 \
+ -c.electronVersion="$(</usr/lib/electron17/version)"
tar -C "${_unpackdir}" -Jxf "${_outfile}"
echo "Deleting Electron ($(du -h "$_electron" | awk '{print $1}'))..." >&2
@@ -74,7 +74,7 @@ build() {
install -D -m 0755 /dev/null "${_unpackdir}/usr/bin/stretchly"
cat >"${_unpackdir}/usr/bin/stretchly" <<EOF
#!/bin/sh
-exec electron '/usr/lib/$(sed -E "s/'/'\\\\''/g" <<<"${_appname}")/' "\$@"
+exec electron17 '/usr/lib/$(sed -E "s/'/'\\\\''/g" <<<"${_appname}")/' "\$@"
EOF
}