summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorl422020-07-26 13:07:20 +0500
committerl422020-07-26 13:24:17 +0500
commitf76446acdd63520981a7a9bf99f66bf047c860be (patch)
tree61a1ade75d66ae70ac9233056e8b0d40ace1aab7
downloadaur-f76446acdd63520981a7a9bf99f66bf047c860be.tar.gz
Initial add. Version 1.0.0
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rw-r--r--Stretchly.install11
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1cc4f286b3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = stretchly-bin
+ pkgdesc = Break time reminder app
+ pkgver = 1.0.0
+ pkgrel = 1933
+ url = https://github.com/hovancik/stretchly/
+ install = Stretchly.install
+ arch = x86_64
+ license = BSD
+ depends = c-ares
+ depends = ffmpeg
+ depends = gtk3
+ depends = http-parser
+ depends = libevent
+ depends = libvpx
+ depends = libxslt
+ depends = libxss
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ depends = libnotify
+ depends = libappindicator-gtk3
+ source = https://github.com/hovancik/stretchly/releases/download/1.0.0/Stretchly-1.0.0.pacman
+ source = LICENSE::https://github.com/hovancik/stretchly/blob/master/LICENSE
+ sha256sums = 368b077ff202f61bef22dbc3ab907420177c1d5c3ac094a72883232c47ae72d2
+ sha256sums = d4262f71a6c02b19bdbdf760033803c0c7ca24acf2591ba425633f7e3315790a
+
+pkgname = stretchly-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ee10870e900
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: l42 <i at tfwno dot gf>
+pkgname=stretchly-bin
+_pkgname=Stretchly
+pkgver=1.0.0
+pkgrel=1
+_rlsver=v1.0.0
+pkgdesc="Break time reminder app"
+arch=('x86_64')
+url="https://github.com/hovancik/stretchly/"
+license=('BSD')
+provides=('stretchly')
+conflicts=('stretchly')
+depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3')
+install=${_pkgname}.install
+source=(
+ "https://github.com/hovancik/stretchly/releases/download/$_rlsver/$_pkgname-$pkgver.pacman"
+ "LICENSE::https://github.com/hovancik/stretchly/blob/$_rlsver/LICENSE"
+)
+sha256sums=(
+ '368b077ff202f61bef22dbc3ab907420177c1d5c3ac094a72883232c47ae72d2'
+ 'f3ef648ba055efa4299fcb25d7d6cef232caa72e1a9461b3a29cfdd0812940c7'
+)
+
+package() {
+ # copy binaries to fakeroot
+ cp -r opt usr ${pkgdir}
+
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/Stretchly.install b/Stretchly.install
new file mode 100644
index 000000000000..db16d2db5170
--- /dev/null
+++ b/Stretchly.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}