summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-09-29 08:24:58 -0700
committerAndy Weidenbaum2015-09-29 08:24:58 -0700
commit25645e6fb98640a7e735b596c6b0eb91fd3a0683 (patch)
tree248a179a675c2525158d7e80c0b0377d7228f645
downloadaur-stribogsum.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a37ef8f23c70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = stribogsum
+ pkgdesc = The Stribog hash function, developed by the Federal Security Service (FSB) and InfoTeKS
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.gostcrypt.org/download.php
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = make
+ source = https://www.gostcrypt.org/download/1.0/linux/Stribogsum.tar.gz
+ sha256sums = 978e81f7de8d4d13c3e11fc2122261146f4b045adebfc20d5a41c200dd9c9bed
+
+pkgname = stribogsum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b5b5a4e1883
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=stribogsum
+pkgver=1.0
+pkgrel=1
+pkgdesc="The Stribog hash function, developed by the Federal Security Service (FSB) and InfoTeKS"
+arch=('i686' 'x86_64')
+makedepends=('make')
+url="https://www.gostcrypt.org/download.php"
+license=('GPL3')
+source=(https://www.gostcrypt.org/download/$pkgver/linux/${pkgname^}.tar.gz)
+sha256sums=('978e81f7de8d4d13c3e11fc2122261146f4b045adebfc20d5a41c200dd9c9bed')
+
+build() {
+ cd "$srcdir/${pkgname^}"
+
+ msg2 'Building...'
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname^}"
+
+ msg2 'Installing...'
+ install -Dm 755 stribogsum "$pkgdir/usr/bin/stribogsum"
+}