summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-08-05 21:54:47 +0200
committerChristopher Arndt2019-08-05 21:54:47 +0200
commited86a28c64f5e6af9ee903b1fca4cb40c25a7eb4 (patch)
tree3817fa508b95118ed973187c711fe9c2e9c0ea8e
downloadaur-ed86a28c64f5e6af9ee903b1fca4cb40c25a7eb4.tar.gz
Add new package 'string.machine'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD36
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f7682930322
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = string-machine
+ pkgdesc = A virtual-analog string ensemble synthesizer LV2 and VST2 plugin
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/jpcima/string-machine
+ arch = i686
+ arch = x86_64
+ groups = pro-audio
+ groups = lv2-plugins
+ groups = vst-plugins
+ license = Boost
+ makedepends = boost
+ makedepends = git
+ makedepends = mesa
+ depends = cairo
+ source = https://github.com/jpcima/string-machine/releases/download/v0.1.0/string-machine-0.1.0.tar.gz
+ sha256sums = 5b0d2eb2185199c1de6c7c35700a2caafbc6ba564529a2e7614c15c3aceacc6f
+
+pkgname = string-machine
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..74df39601140
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+string-machine-*.tar.gz
+string-machine-*.tar.xz
+string-machine-*.src.tar.gz
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36031e29a93f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname=string-machine
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A virtual-analog string ensemble synthesizer LV2 and VST2 plugin"
+arch=('i686' 'x86_64')
+url="https://github.com/jpcima/string-machine"
+license=('Boost')
+depends=('cairo')
+makedepends=('boost' 'git' 'mesa')
+groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
+source=("https://github.com/jpcima/string-machine/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('5b0d2eb2185199c1de6c7c35700a2caafbc6ba564529a2e7614c15c3aceacc6f')
+
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Create installation directories
+ install -dm755 "${pkgdir}"/usr/lib/vst
+ install -dm755 "${pkgdir}"/usr/lib/lv2/${pkgname}.lv2
+ # LV2 bundle
+ install -Dm644 bin/${pkgname}.lv2/*.ttl -t \
+ "${pkgdir}"/usr/lib/lv2/${pkgname}.lv2
+ install -Dm755 bin/${pkgname}.lv2/*.so -t \
+ "${pkgdir}"/usr/lib/lv2/${pkgname}.lv2
+ # VST shared library
+ install -m755 bin/${pkgname}-vst.so "${pkgdir}"/usr/lib/vst
+}