summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-02-02 15:21:01 +0100
committeraksr2016-02-02 15:21:01 +0100
commit120a179838287593585ec724de1336f8c652b439 (patch)
treeeb57fc906e86f768c3ff0878b4fb58b10da3a484
parent7f7cc61782d0786608be1dd37fc73b04b1029ab5 (diff)
downloadaur-strings-git.tar.gz
Better way to get pkgver?
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD1
2 files changed, 3 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1c5eed4b2b8..d8514881a4ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 14:20:54 UTC 2016
pkgbase = strings-git
pkgdesc = A custom, Unicode-competent version of the BSD strings utility.
pkgver = r9.c455a79
diff --git a/PKGBUILD b/PKGBUILD
index c0997aa5fced..7087c61114ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,6 +23,7 @@ noextract=()
_gourl=robpike.io/cmd/strings
pkgver() {
+ GOPATH="$srcdir" go get -d ${_gourl}
cd "$srcdir/src/${_gourl}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}