summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Rossini2019-05-14 23:02:17 +0200
committerRoberto Rossini2019-05-14 23:02:17 +0200
commit3bb17d798fbb598eb6f25f09502eae673f67b7d6 (patch)
tree023b3e8135c9202f44dc25467429cbacf11f8160
parentfcd753b7554b08a2aaae7c3070674066e025aefc (diff)
downloadaur-3bb17d798fbb598eb6f25f09502eae673f67b7d6.tar.gz
Code style fixes
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
3 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ada84ce6482..3df2e089da6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = stringtie
- pkgdesc = A fast and highly efficient assembler of RNA-Seq alignments into potential transcripts.
+ pkgdesc = A fast and highly efficient assembler of RNA-Seq alignments into potential transcripts
pkgver = 1.3.6
- pkgrel = 1
+ pkgrel = 2
url = https://ccb.jhu.edu/software/stringtie/index.shtml
arch = x86_64
license = Artistic2.0
depends = gcc-libs
depends = zlib
- provides = stringtie
- conflicts = stringtie
source = https://ccb.jhu.edu/software/stringtie/dl/stringtie-1.3.6.tar.gz
sha256sums = 9dbdf01ab3282dc6eb647409920b53f8e0df45f4c45faf9d6b5ca135a3738ee8
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 8132e149e0e4..85b92b0f2d80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=stringtie
pkgver=1.3.6
-pkgrel=1
+pkgrel=2
pkgdesc="A fast and highly efficient assembler of RNA-Seq\
- alignments into potential transcripts."
+ alignments into potential transcripts"
url='https://ccb.jhu.edu/software/stringtie/index.shtml'
arch=('x86_64')
@@ -13,28 +13,23 @@ license=('Artistic2.0')
depends=('gcc-libs' 'zlib')
-provides=('stringtie')
-conflicts=('stringtie')
-
source=("https://ccb.jhu.edu/software/$pkgname/dl/$pkgname-$pkgver.tar.gz")
sha256sums=('9dbdf01ab3282dc6eb647409920b53f8e0df45f4c45faf9d6b5ca135a3738ee8')
build() {
- cd $srcdir/$pkgname-$pkgver/
+ cd $pkgname-$pkgver/
make release
}
check() {
- cd $srcdir/$pkgname-$pkgver/
+ cd $pkgname-$pkgver/
./stringtie --version | grep -Fxq "$pkgver"
}
package() {
- cd $srcdir/$pkgname-$pkgver/
+ cd $pkgname-$pkgver/
- install -Dm755 $srcdir/$pkgname-$pkgver/$pkgname $pkgdir/usr/bin/$pkgname
-
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
}