summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Rossini2019-07-31 00:01:22 +0200
committerRoberto Rossini2019-07-31 00:01:22 +0200
commit70472c6faa360bbe4ef75d1f83563c9f750e641f (patch)
tree6e59d879ed5252fb528a487bb3e9a3417594b4d6
parent3bb17d798fbb598eb6f25f09502eae673f67b7d6 (diff)
downloadaur-70472c6faa360bbe4ef75d1f83563c9f750e641f.tar.gz
Update to StringTie 2.0. Improve test section
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3df2e089da6f..e8c9dd88a809 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = stringtie
pkgdesc = A fast and highly efficient assembler of RNA-Seq alignments into potential transcripts
- pkgver = 1.3.6
- pkgrel = 2
+ pkgver = 2.0
+ pkgrel = 1
url = https://ccb.jhu.edu/software/stringtie/index.shtml
arch = x86_64
license = Artistic2.0
depends = gcc-libs
depends = zlib
- source = https://ccb.jhu.edu/software/stringtie/dl/stringtie-1.3.6.tar.gz
- sha256sums = 9dbdf01ab3282dc6eb647409920b53f8e0df45f4c45faf9d6b5ca135a3738ee8
+ source = https://ccb.jhu.edu/software/stringtie/dl/stringtie-2.0.tar.gz
+ sha256sums = 654da1b85a1eca9ad0d410d0e356ee8f05c62d89d6d4385b07bcd0d03c6b25eb
pkgname = stringtie
-
diff --git a/PKGBUILD b/PKGBUILD
index 85b92b0f2d80..ff368bd90b34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Roberto Rossini ("robymetallo") <roberto.rossini.9533@student.uu.se>
pkgname=stringtie
-pkgver=1.3.6
-pkgrel=2
+pkgver=2.0
+pkgrel=1
pkgdesc="A fast and highly efficient assembler of RNA-Seq\
alignments into potential transcripts"
@@ -14,7 +14,7 @@ license=('Artistic2.0')
depends=('gcc-libs' 'zlib')
source=("https://ccb.jhu.edu/software/$pkgname/dl/$pkgname-$pkgver.tar.gz")
-sha256sums=('9dbdf01ab3282dc6eb647409920b53f8e0df45f4c45faf9d6b5ca135a3738ee8')
+sha256sums=('654da1b85a1eca9ad0d410d0e356ee8f05c62d89d6d4385b07bcd0d03c6b25eb')
build() {
cd $pkgname-$pkgver/
@@ -24,7 +24,7 @@ build() {
check() {
cd $pkgname-$pkgver/
- ./stringtie --version | grep -Fxq "$pkgver"
+ make test
}
package() {
@@ -32,4 +32,3 @@ package() {
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
}
-