summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze2016-10-20 16:15:52 +0200
committerNoel Kuntze2016-10-20 16:15:52 +0200
commit036d4e6c14d9bf5d838c1f731e24caf27d313739 (patch)
treebee7362b4780dcac0b761ba910b45ea4bc7547dd
parent2b12797e8edb16a3b39896a0eb5f47e08bce4847 (diff)
downloadaur-036d4e6c14d9bf5d838c1f731e24caf27d313739.tar.gz
bump to 5.5.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d2b544df551..ac9325bd251b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Sep 9 10:17:20 UTC 2016
+# Thu Oct 20 14:14:43 UTC 2016
pkgbase = strongswan
pkgdesc = open source IPsec implementation
- pkgver = 5.5.0
+ pkgver = 5.5.1
pkgrel = 1
url = http://www.strongswan.org
arch = i686
@@ -28,6 +28,7 @@ pkgbase = strongswan
conflicts = openswan
options = !libtool
backup = etc/ipsec.conf
+ backup = etc/ipsec.secrets
backup = etc/swanctl/swanctl.conf
backup = etc/strongswan.conf
backup = etc/strongswan.d/charon-logging.conf
@@ -96,9 +97,9 @@ pkgbase = strongswan
backup = etc/strongswan.d/charon/xcbc.conf
backup = etc/strongswan.d/charon/chapoly.conf
backup = etc/strongswan.d/charon/unity.conf
- source = https://download.strongswan.org/strongswan-5.5.0.tar.bz2
+ source = https://download.strongswan.org/strongswan-5.5.1.tar.bz2
source = configure_ac.patch
- sha256sums = 58463998ac6725eac3687e8a20c1f69803c3772657076d06c43386a24b4c8454
+ sha256sums = 720b301991f77bdedd8d551a956f52e2d11686a0ec18e832094f86cf2b842ab7
sha256sums = 003750d77fa501075f1fdb6f55926dc544407c5dd26e2fd8d5eb4917ddf0b3f7
pkgname = strongswan
diff --git a/PKGBUILD b/PKGBUILD
index d171e9c6c19e..691b7b525489 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,20 @@
# Maintainer: Thermi <noel [at] familie-kuntze dot de>
pkgname=strongswan
-pkgver=5.5.0
+pkgver=5.5.1
pkgrel=1
pkgdesc="open source IPsec implementation"
url='http://www.strongswan.org'
license=("GPL")
arch=('i686' 'x86_64')
+# If you want networkmanager support, add a makedepend and depend for libnm-glib
depends=('curl' 'gmp' 'iproute2' 'openssl' 'sqlite' 'libcap' 'libsystemd' 'pam')
makedepends=('curl' 'gmp' 'iproute2' 'openssl' 'sqlite' 'libcap' 'libsystemd' 'systemd' 'pam')
conflicts=('openswan')
options=(!libtool)
backup=(
etc/ipsec.conf
+ etc/ipsec.secrets
etc/swanctl/swanctl.conf
etc/strongswan.conf
etc/strongswan.d/{charon-logging.conf,charon.conf,pki.conf,pool.conf,scepclient.conf,starter.conf,swanctl.conf}
@@ -40,9 +42,9 @@ source=("https://download.strongswan.org/strongswan-${pkgver}.tar.bz2"
# md5 is broken. We use sha256 now. Alternatively, we could check the signature of the file, but that
# doesn't yield any more security and just increases the work users initially have to invest.
-sha256sums=('58463998ac6725eac3687e8a20c1f69803c3772657076d06c43386a24b4c8454'
+sha256sums=('720b301991f77bdedd8d551a956f52e2d11686a0ec18e832094f86cf2b842ab7'
'003750d77fa501075f1fdb6f55926dc544407c5dd26e2fd8d5eb4917ddf0b3f7')
-
+
# We don't build libipsec because it would get loaded before kernel-netlink and netkey, which
# would case processing to be handled in user space. Also, the plugin is experimental. If you need it,
# add --enable-libipsec and --enable-kernel-libipsec
@@ -74,6 +76,7 @@ build() {
--enable-aesni --enable-eap-ttls --enable-radattr --enable-xauth-pam --enable-xauth-noauth \
--enable-eap-dynamic --enable-eap-peap --enable-eap-tls --enable-chapoly --enable-unity \
--with-capabilities=libcap
+# if you want networkmanager support, add --enable-nm
# --enable-ruby-gems --enable-python-eggs
make
}