summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze2016-03-26 18:41:32 +0100
committerNoel Kuntze2016-03-26 18:41:32 +0100
commitabd7e7b3d3273be9fe71f469500692be2ebb8121 (patch)
tree204093be26d9b988ae784ffb41e4011f669ee30e
parentfd3da5d1cc598998825f9b9956e0e057ffb2bc2d (diff)
downloadaur-abd7e7b3d3273be9fe71f469500692be2ebb8121.tar.gz
strongswan: Bump to 5.4.0
-rw-r--r--PKGBUILD8
-rw-r--r--configure_ac.patch31
2 files changed, 19 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b92da9b88f81..3903d5325820 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Maintainer: Thermi <noel [at] familie-kuntze dot de>
pkgname=strongswan
-pkgver=5.3.5
+pkgver=5.4.0
pkgrel=1
pkgdesc="open source IPsec implementation"
url='http://www.strongswan.org'
@@ -39,8 +39,8 @@ source=("https://download.strongswan.org/strongswan-${pkgver}.tar.bz2"
# md5 is broken. We use sha256 now. Alternatively, we could check the signature of the file, but that
# doesn't yield any more security and just increases the work users initially have to invest.
-sha256sums=('2c84b663da652b1ff180a1a73c24a3d7b9fc4b9b8ba6bd07f94a1e33092e6350'
- 'cbf5af332c72bc27b9defa4c3067d6b7be0c873282e3d1874f980cc8cce74ad2')
+sha256sums=('f8288faaea6a9cd8a7d413c0b76b7922be5da3dfcd01fd05cb30d2c55d3bbe89'
+ '003750d77fa501075f1fdb6f55926dc544407c5dd26e2fd8d5eb4917ddf0b3f7')
# We don't build libipsec because it would get loaded before kernel-netlink and netkey, which
# would case processing to be handled in user space. Also, the plugin is experimental. If you need it,
@@ -48,7 +48,7 @@ sha256sums=('2c84b663da652b1ff180a1a73c24a3d7b9fc4b9b8ba6bd07f94a1e33092e6350'
prepare()
{
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < "${srcdir}/configure_ac.patch"
+ patch -p1 -l < "${srcdir}/configure_ac.patch"
autoreconf
}
diff --git a/configure_ac.patch b/configure_ac.patch
index 26b0e6a76787..5299520638ea 100644
--- a/configure_ac.patch
+++ b/configure_ac.patch
@@ -1,17 +1,16 @@
---- a/configure.ac 2015-11-26 14:38:10.000000000 +0500
-+++ b/configure.ac 2016-03-04 19:00:03.395406767 +0500
-@@ -935,11 +935,11 @@
- AC_MSG_ERROR([not found (try --with-systemdsystemunitdir)])
- fi
-
-- PKG_CHECK_MODULES(systemd_daemon, [libsystemd-daemon])
-+ PKG_CHECK_MODULES(systemd_daemon, [libsystemd])
- AC_SUBST(systemd_daemon_CFLAGS)
- AC_SUBST(systemd_daemon_LIBS)
-
-- PKG_CHECK_MODULES(systemd_journal, [libsystemd-journal])
-+ PKG_CHECK_MODULES(systemd_journal, [libsystemd])
- AC_SUBST(systemd_journal_CFLAGS)
- AC_SUBST(systemd_journal_LIBS)
- fi
+--- a/configure.ac 2016-03-22 09:36:03.000000000 +0100
++++ b/configure.ac 2016-03-26 18:35:44.697586161 +0100
+@@ -946,10 +946,10 @@
+ PKG_CHECK_MODULES(systemd, [libsystemd >= 209],
+ [AC_SUBST(systemd_CFLAGS)
+ AC_SUBST(systemd_LIBS)],
+- [PKG_CHECK_MODULES(systemd_daemon, [libsystemd-daemon])
++ [PKG_CHECK_MODULES(systemd_daemon, [libsystemd])
+ AC_SUBST(systemd_daemon_CFLAGS)
+ AC_SUBST(systemd_daemon_LIBS)
+- PKG_CHECK_MODULES(systemd_journal, [libsystemd-journal])
++ PKG_CHECK_MODULES(systemd_journal, [libsystemd])
+ AC_SUBST(systemd_journal_CFLAGS)
+ AC_SUBST(systemd_journal_LIBS)]
+ )