summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze2017-02-04 19:22:28 +0100
committerNoel Kuntze2017-02-04 19:22:28 +0100
commitcb3e345f33f398ea1f9b620ce2bd79d152ae1812 (patch)
treef5c1d00f1ef22918b02bea3c2dfd2ce98467e7f1
parent45c7e3541a79354629a3df7014c24fc225a9610c (diff)
downloadaur-cb3e345f33f398ea1f9b620ce2bd79d152ae1812.tar.gz
Add two patches, bump PKGREL
-rw-r--r--.SRCINFO8
-rw-r--r--2222-charon-systemd-sighup.patch33
-rw-r--r--2238-eap-dynamic-auth.patch38
-rw-r--r--PKGBUILD12
4 files changed, 86 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03069b92d482..dcbfdc131ba1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 23 15:10:31 UTC 2017
+# Sat Feb 4 18:21:59 UTC 2017
pkgbase = strongswan
pkgdesc = open source IPsec implementation
pkgver = 5.5.1
- pkgrel = 4
+ pkgrel = 5
url = http://www.strongswan.org
arch = i686
arch = x86_64
@@ -105,9 +105,13 @@ pkgbase = strongswan
source = https://download.strongswan.org/strongswan-5.5.1.tar.bz2
source = https://download.strongswan.org/strongswan-5.5.1.tar.bz2.sig
source = configure_ac.patch
+ source = 2222-charon-systemd-sighup.patch
+ source = 2238-eap-dynamic-auth.patch
sha256sums = 720b301991f77bdedd8d551a956f52e2d11686a0ec18e832094f86cf2b842ab7
sha256sums = SKIP
sha256sums = 003750d77fa501075f1fdb6f55926dc544407c5dd26e2fd8d5eb4917ddf0b3f7
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = strongswan
diff --git a/2222-charon-systemd-sighup.patch b/2222-charon-systemd-sighup.patch
new file mode 100644
index 000000000000..544612c20755
--- /dev/null
+++ b/2222-charon-systemd-sighup.patch
@@ -0,0 +1,33 @@
+index 5c7bbd779..fc93e2182 100644
+--- a/src/charon-systemd/charon-systemd.c
++++ b/src/charon-systemd/charon-systemd.c
+@@ -241,6 +241,7 @@ static int run()
+ sigset_t set;
+
+ sigemptyset(&set);
++ sigaddset(&set, SIGHUP);
+ sigaddset(&set, SIGTERM);
+ sigprocmask(SIG_BLOCK, &set, NULL);
+
+@@ -262,6 +263,21 @@ static int run()
+ }
+ switch (sig)
+ {
++ case SIGHUP:
++ {
++ DBG1(DBG_DMN, "signal of type SIGHUP received. Reloading "
++ "configuration");
++ if (lib->settings->load_files(lib->settings, lib->conf, FALSE))
++ {
++ charon->load_loggers(charon, NULL, FALSE);
++ lib->plugins->reload(lib->plugins, NULL);
++ }
++ else
++ {
++ DBG1(DBG_DMN, "reloading config failed, keeping old");
++ }
++ break;
++ }
+ case SIGTERM:
+ {
+ DBG1(DBG_DMN, "SIGTERM received, shutting down");
diff --git a/2238-eap-dynamic-auth.patch b/2238-eap-dynamic-auth.patch
new file mode 100644
index 000000000000..17b954ea7d38
--- /dev/null
+++ b/2238-eap-dynamic-auth.patch
@@ -0,0 +1,38 @@
+diff --git a/src/libcharon/plugins/eap_dynamic/eap_dynamic.c b/src/libcharon/plugins/eap_dynamic/eap_dynamic.c
+index d0f0595de..83ccd3a8a 100644
+--- a/src/libcharon/plugins/eap_dynamic/eap_dynamic.c
++++ b/src/libcharon/plugins/eap_dynamic/eap_dynamic.c
+@@ -94,6 +94,13 @@ static eap_method_t *load_method(private_eap_dynamic_t *this,
+ return method;
+ }
+
++METHOD(eap_method_t, get_auth, auth_cfg_t*,
++ private_eap_dynamic_t *this)
++{
++ /* get_auth() is only registered if the EAP method supports it */
++ return this->method->get_auth(this->method);
++}
++
+ /**
+ * Select the first method we can instantiate and is supported by both peers.
+ */
+@@ -135,6 +142,10 @@ static void select_method(private_eap_dynamic_t *this)
+ this->method = load_method(this, entry->type, entry->vendor);
+ if (this->method)
+ {
++ if (this->method->get_auth)
++ {
++ this->public.interface.get_auth = _get_auth;
++ }
+ if (entry->vendor)
+ {
+ DBG1(DBG_IKE, "vendor specific EAP method %d-%d selected",
+@@ -211,6 +222,7 @@ METHOD(eap_method_t, process, status_t,
+ /* restart with a different method */
+ this->method->destroy(this->method);
+ this->method = NULL;
++ this->public.interface.get_auth = NULL;
+ return initiate(this, out);
+ }
+ if (!this->other_types)
+
diff --git a/PKGBUILD b/PKGBUILD
index bc5993f5215b..c7272883bd42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=strongswan
pkgver=5.5.1
-pkgrel=4
+pkgrel=5
pkgdesc="open source IPsec implementation"
url='http://www.strongswan.org'
license=("GPL")
@@ -39,6 +39,8 @@ vici.conf,x509.conf,xauth-eap.conf,xauth-generic.conf,xcbc.conf,unity.conf}
source=("https://download.strongswan.org/strongswan-${pkgver}.tar.bz2"
"https://download.strongswan.org/strongswan-${pkgver}.tar.bz2.sig"
"configure_ac.patch"
+ "2222-charon-systemd-sighup.patch"
+ "2238-eap-dynamic-auth.patch"
)
validpgpkeys=("948F158A4E76A27BF3D07532DF42C170B34DBA77")
@@ -47,7 +49,9 @@ validpgpkeys=("948F158A4E76A27BF3D07532DF42C170B34DBA77")
# doesn't yield any more security and just increases the work users initially have to invest.
sha256sums=('720b301991f77bdedd8d551a956f52e2d11686a0ec18e832094f86cf2b842ab7'
'SKIP'
- '003750d77fa501075f1fdb6f55926dc544407c5dd26e2fd8d5eb4917ddf0b3f7')
+ '003750d77fa501075f1fdb6f55926dc544407c5dd26e2fd8d5eb4917ddf0b3f7'
+ 'SKIP'
+ 'SKIP')
# We don't build libipsec because it would get loaded before kernel-netlink and netkey, which
# would case processing to be handled in user space. Also, the plugin is experimental. If you need it,
@@ -56,6 +60,8 @@ prepare()
{
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -l < "${srcdir}/configure_ac.patch"
+ patch -p1 -l < "${srcdir}/2222-charon-systemd-sighup.patch"
+ patch -p1 -l < "${srcdir}/2238-eap-dynamic-auth.patch"
autoreconf
}
@@ -80,7 +86,7 @@ build() {
--enable-aesni --enable-eap-ttls --enable-radattr --enable-xauth-pam --enable-xauth-noauth \
--enable-eap-dynamic --enable-eap-peap --enable-eap-tls --enable-chapoly --enable-unity \
--with-capabilities=libcap --enable-newhope --enable-ntru --enable-mgf1 --enable-sha3 \
- --enable-test-vectors --enable-bliss
+ --enable-bliss
# if you want networkmanager support, add --enable-nm
# --enable-ruby-gems --enable-python-eggs
make