summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze2016-03-04 18:32:46 +0100
committerNoel Kuntze2016-03-04 18:32:46 +0100
commitfd3da5d1cc598998825f9b9956e0e057ffb2bc2d (patch)
tree3fa1038400141465aea68f44d02b30ee1ccbb9cf
parent2d68c99341d86ab6e2dd0f526b7002dd754a586c (diff)
downloadaur-fd3da5d1cc598998825f9b9956e0e057ffb2bc2d.tar.gz
PKGBUILD: Add fix for changed libsystemd pkg names
configure_ac: patch for changed libsystemd pkg names
-rw-r--r--PKGBUILD15
-rw-r--r--configure_ac.patch17
2 files changed, 29 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a99abaea5f05..b92da9b88f81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,18 +33,27 @@ revocation.conf,sha1.conf,sha2.conf,socket-default.conf,sql.conf,sqlite.conf,ssh
vici.conf,x509.conf,xauth-eap.conf,xauth-generic.conf,xcbc.conf,chapoly.conf,unity.conf}
)
-source=("https://download.strongswan.org/strongswan-${pkgver}.tar.bz2")
+source=("https://download.strongswan.org/strongswan-${pkgver}.tar.bz2"
+ "configure_ac.patch"
+ )
# md5 is broken. We use sha256 now. Alternatively, we could check the signature of the file, but that
# doesn't yield any more security and just increases the work users initially have to invest.
-sha256sums=('2c84b663da652b1ff180a1a73c24a3d7b9fc4b9b8ba6bd07f94a1e33092e6350')
+sha256sums=('2c84b663da652b1ff180a1a73c24a3d7b9fc4b9b8ba6bd07f94a1e33092e6350'
+ 'cbf5af332c72bc27b9defa4c3067d6b7be0c873282e3d1874f980cc8cce74ad2')
# We don't build libipsec because it would get loaded before kernel-netlink and netkey, which
# would case processing to be handled in user space. Also, the plugin is experimental. If you need it,
# add --enable-libipsec and --enable-kernel-libipsec
+prepare()
+{
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < "${srcdir}/configure_ac.patch"
+ autoreconf
+}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr \
--sbindir=/usr/bin \
diff --git a/configure_ac.patch b/configure_ac.patch
new file mode 100644
index 000000000000..26b0e6a76787
--- /dev/null
+++ b/configure_ac.patch
@@ -0,0 +1,17 @@
+--- a/configure.ac 2015-11-26 14:38:10.000000000 +0500
++++ b/configure.ac 2016-03-04 19:00:03.395406767 +0500
+@@ -935,11 +935,11 @@
+ AC_MSG_ERROR([not found (try --with-systemdsystemunitdir)])
+ fi
+
+- PKG_CHECK_MODULES(systemd_daemon, [libsystemd-daemon])
++ PKG_CHECK_MODULES(systemd_daemon, [libsystemd])
+ AC_SUBST(systemd_daemon_CFLAGS)
+ AC_SUBST(systemd_daemon_LIBS)
+
+- PKG_CHECK_MODULES(systemd_journal, [libsystemd-journal])
++ PKG_CHECK_MODULES(systemd_journal, [libsystemd])
+ AC_SUBST(systemd_journal_CFLAGS)
+ AC_SUBST(systemd_journal_LIBS)
+ fi
+