summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMusikolo2018-07-05 00:34:57 -0500
committerMusikolo2018-07-05 00:34:57 -0500
commit6a9bc16d895fe9682e026d4fe90a86dd6bc7d6d9 (patch)
treecbb1e34c7625d8950da30fd701164435068aba8e
parent082f54638d4826dc8aaee2649f437e9f9f9a1f6e (diff)
downloadaur-6a9bc16d895fe9682e026d4fe90a86dd6bc7d6d9.tar.gz
Upgrade to version 0.2.0. Remove aws-cli as execution dependency.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 164a2c404cfb..b07f0c8019cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jun 24 04:10:00 UTC 2018
+# Thu Jul 5 05:30:07 UTC 2018
pkgbase = stsauth
pkgdesc = CLI tool for fetching AWS tokens. Creates a temporary AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY that can be used with cli tools such as awscli, ansible, terraform and more.
- pkgver = 0.1.3
- pkgrel = 2
+ pkgver = 0.2.0
+ pkgrel = 1
url = https://github.com/cshamrick/stsauth
arch = any
license = MIT
@@ -15,7 +15,6 @@ pkgbase = stsauth
makedepends = python2-configparser
makedepends = python-requests
makedepends = python-requests-ntlm
- depends = aws-cli
depends = python-boto3
depends = python-beautifulsoup4
depends = python-click
diff --git a/PKGBUILD b/PKGBUILD
index 4caf2c0f2422..6b63dca9a65f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer Musikolo <musikolo {at} hotmail [dot] com>
pkgname=stsauth
-pkgver=0.1.3
+pkgver=0.2.0
pkgdesc="CLI tool for fetching AWS tokens. Creates a temporary AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY that can be used with cli tools such as awscli, ansible, terraform and more."
-pkgrel=2
+pkgrel=1
arch=(any)
url="https://github.com/cshamrick/stsauth"
license=(MIT)
makedepends=(aws-cli python-pip python-boto3 python-beautifulsoup4 python-click python2-configparser python-requests python-requests-ntlm)
-depends=(aws-cli python-boto3 python-beautifulsoup4 python-click python2-configparser python-requests python-requests-ntlm)
+depends=(python-boto3 python-beautifulsoup4 python-click python2-configparser python-requests python-requests-ntlm)
options=()
source=("git+https://github.com/cshamrick/${pkgname}.git")
md5sums=('SKIP')
package() {
mkdir -p "${pkgdir}"
- pip install --root="${pkgdir}" ${pkgname}
+ pip install --root="${pkgdir}" ${pkgname}==${pkgver} --no-warn-script-location
}